Nikon

NIS-Elements
Documentation

User’s Guide
(Ver. 3.06)
Thank you very much for choosing Nikon.
This manual explains installation and use of the NIS-Elements Documentation. For trouble-free operation, read this manual before using the program.

No part of this manual may be reproduced without Nikon’s permission. The content of this manual is subject to change without notice. Nikon has carefully prepared this manual. However, we make no expressed or implied warranty of any kind and assume no responsibility for such errors or omissions. Be sure to read the instruction manuals for the microscope and PC you plan to use with the NIS-Elements Documentation.

Trademarks:
Microsoft® and Windows® are either registered trademarks or trademarks of Microsoft Corporation in the United States or other countries. Products and brand names are trademarks or registered trademarks of their respective companies. The “TM” and ® marks are not used to identify registered trademarks and trademarks in this manual.

To run NIS-Elements Documentation optimally, the following specifications are recommended. Recommended PC Environment:
- CPU: Pentium IV, 3.2 GHz or faster
- RAM: 1GB or higher
- Operating system: Windows XP SP2 (English)
- Hard disk space: 600MB of available hard disk space for installation
- Display settings: 1280 x 1024 (True Color mode)
- User rights: Administrators for installation and operation

*Operation cannot be guaranteed on all computer models. For further information, contact your nearest Nikon representatives.
List of Contents

Chapter 1 Installation and Setup ............................................................ 9
  1.1 NIS-Elements Installation ................................................................. 9
  1.1.1 Quick Start .................................................................................. 9
  1.1.2 The DVD-ROM Content ............................................................... 9
  1.1.3 The Installation Process ............................................................... 9
  1.1.4 Additional Module/Device Installation ......................................... 13
  1.1.5 Sample Database Installation ...................................................... 13
  1.1.6 The software Copy Protection ...................................................... 14
  1.2 Command Line Options .................................................................... 15
    1.2.1 Syntax and Example ................................................................. 15
    1.2.2 Switches ................................................................................... 15

Chapter 2 Application Appearance ...................................................... 17
  2.1 NIS-Elements Screen ...................................................................... 17
  2.2 Modifying Layout ............................................................................ 20
    2.2.1 Layout Manager ......................................................................... 20
    2.2.2 Layout Setup ............................................................................. 21
    2.2.3 Docking Panes without Using the Layout Manager ................. 26
    2.2.4 Control Windows ...................................................................... 27
  2.3 Organizer ......................................................................................... 30
    2.3.1 Image Filter ............................................................................... 32
    2.3.2 Operations with Images .............................................................. 34
    2.3.3 Thumbnail Displaying Options .................................................. 35
    2.3.4 Ordering of Images ................................................................... 35
    2.3.5 Grouping of Images .................................................................. 36
    2.3.6 Adjusting the Organizer Layout ............................................... 36

Chapter 3 Setting the Hardware Up ..................................................... 37
  3.1 Cameras ............................................................................................ 37
  3.2 Configuring Attached Hardware ..................................................... 40
    3.2.1 Creating New Optical Configuration ........................................ 40
    3.2.2 Managing Optical Configurations ............................................ 45
    3.2.3 Objectives and Calibrations ...................................................... 46
    3.2.4 Units ......................................................................................... 47
  3.3 User Management ............................................................................ 48
    3.3.1 Group Settings .......................................................................... 49
    3.3.2 Defaults for this Page ............................................................... 50
<table>
<thead>
<tr>
<th>Chapter 4</th>
<th>Capturing Images</th>
<th>51</th>
</tr>
</thead>
<tbody>
<tr>
<td>4.1</td>
<td>Images Capturing</td>
<td>51</td>
</tr>
<tr>
<td>4.1.1</td>
<td>Single Image Capture</td>
<td>51</td>
</tr>
<tr>
<td>4.2</td>
<td>Time Lapse Acquisition</td>
<td>52</td>
</tr>
<tr>
<td>4.2.1</td>
<td>Time Schedule</td>
<td>52</td>
</tr>
<tr>
<td>4.2.2</td>
<td>Auto Focus</td>
<td>52</td>
</tr>
<tr>
<td>4.2.3</td>
<td>Special Options</td>
<td>53</td>
</tr>
<tr>
<td>4.3</td>
<td>Multipoint Acquisition</td>
<td>54</td>
</tr>
<tr>
<td>4.3.1</td>
<td>To Define a Multipoint Array</td>
<td>55</td>
</tr>
<tr>
<td>4.3.2</td>
<td>To Change a Single Z Coordinate</td>
<td>55</td>
</tr>
<tr>
<td>4.3.3</td>
<td>Offset All</td>
<td>55</td>
</tr>
<tr>
<td>4.3.4</td>
<td>Special Options</td>
<td>55</td>
</tr>
<tr>
<td>4.4</td>
<td>Z Series Acquisition</td>
<td>57</td>
</tr>
<tr>
<td>4.4.1</td>
<td>Top/Bottom Position, Step</td>
<td>57</td>
</tr>
<tr>
<td>4.4.2</td>
<td>Home Position, Range</td>
<td>58</td>
</tr>
<tr>
<td>4.4.3</td>
<td>Special Options</td>
<td>58</td>
</tr>
<tr>
<td>4.4.4</td>
<td>Home and All Position</td>
<td>58</td>
</tr>
<tr>
<td>4.5</td>
<td>AVI Acquisition</td>
<td>59</td>
</tr>
<tr>
<td>4.5.1</td>
<td>Capturing AVI movie</td>
<td>59</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Chapter 5</th>
<th>Documents, Archiving</th>
<th>61</th>
</tr>
</thead>
<tbody>
<tr>
<td>5.1</td>
<td>NIS-Elements Document Structure</td>
<td>61</td>
</tr>
<tr>
<td>5.1.1</td>
<td>Image Layers</td>
<td>61</td>
</tr>
<tr>
<td>5.1.2</td>
<td>Document Types in NIS-Elements</td>
<td>61</td>
</tr>
<tr>
<td>5.1.3</td>
<td>Document Window</td>
<td>62</td>
</tr>
<tr>
<td>5.1.4</td>
<td>Working with Vector Objects</td>
<td>64</td>
</tr>
<tr>
<td>5.2</td>
<td>ND2 Files</td>
<td>65</td>
</tr>
<tr>
<td>5.2.1</td>
<td>Browsing ND2 Document</td>
<td>65</td>
</tr>
<tr>
<td>5.3</td>
<td>Working with Documents</td>
<td>68</td>
</tr>
<tr>
<td>5.3.1</td>
<td>Opening Saved Files</td>
<td>68</td>
</tr>
<tr>
<td>5.3.2</td>
<td>Switching between Loaded Documents</td>
<td>69</td>
</tr>
<tr>
<td>5.3.3</td>
<td>Closing Documents</td>
<td>70</td>
</tr>
<tr>
<td>5.3.4</td>
<td>Image Formats</td>
<td>70</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Chapter 6</th>
<th>Image Analysis</th>
<th>72</th>
</tr>
</thead>
<tbody>
<tr>
<td>6.1</td>
<td>Histogram and Look Up Tables</td>
<td>72</td>
</tr>
<tr>
<td>6.1.1</td>
<td>Histogram Window</td>
<td>72</td>
</tr>
<tr>
<td>6.1.2</td>
<td>LUTs</td>
<td>73</td>
</tr>
<tr>
<td>6.2</td>
<td>Measurement</td>
<td>78</td>
</tr>
<tr>
<td>6.2.1</td>
<td>Calibration</td>
<td>78</td>
</tr>
<tr>
<td>6.2.2</td>
<td>Rough Measurement</td>
<td>78</td>
</tr>
<tr>
<td>6.2.3</td>
<td>Manual Measurement</td>
<td>79</td>
</tr>
</tbody>
</table>
8.5 Nikon Eclipse 90i/80i Microscope .............................................................. 144
8.6 Nikon AZ100 Microscope ........................................................................... 145
8.7 Nikon Eclipse LV Series Microscope ......................................................... 147
8.8 Nikon MM 400/800 Microscopes .............................................................. 148
8.9 Nikon MA200 Inverted Metallurgical Microscope .................................... 149
8.10 Nikon TE2000 Microscope .................................................................. 150
8.11 Nikon TI Microscope ............................................................................ 151
1.1 NIS-Elements Installation

1.1.1 Quick Start

- Insert the installation DVD in the DVD-ROM drive. A splash screen automatically appears.
- Install the selected NIS-Elements software version, additional modules, and device drivers.
- Plug the provided HASP key into the USB port of your PC.
- Run NIS-Elements

1.1.2 The DVD-ROM Content

The DVD-R contains the NIS-Elements software itself, Windows system drivers for all supported cameras, drivers and utilities for HASP, documentation in PDF format, a sample image database, and sample image sequences.

1.1.3 The Installation Process

Note that you have to possess the administrator rights to your computer to be able to install NIS-Elements successfully. When the installation DVD is inserted a splash screen appears.

Select the software package to be installed. A welcome dialog box appears. Click [Next] to continue.
Define the folder where NIS-Elements should be installed. We recommend to use the predefined directory. If you want to change the directory anyway, press the [Browse] button and select a new one. Otherwise click [Next].

Now select the cameras you want to use with NIS-Elements.
If your license contains some additional modules besides the NIS-Elements base software, please select them in this window.

**Note:**

*Any module selected will be installed along with NIS-Elements automatically. However, you might not be licensed to use it. The module will run after you get the corresponding code registered in your HASP key.*
If the license contains some device controllers listed in this window, please select them. Finish the installation by clicking the [Install] button.

The setup creates a new program group containing the following items: [NIS-Elements] application shortcut, the HASP key information shortcut, the [Modify Installation] shortcut (for adding hardware drivers, modules, etc.), the [Uninstall] procedure, and the Send Info Tool. A shortcut to NIS-Elements is created on the desktop too. These changes affect all user profiles of your local Windows operating system.
Note:
Clicking the [Uninstall] command deletes all installed files from disk, and removes the NIS-Elements program group from the Start menu as well as it removes the desktop icon.

1.1.4 Additional Module/Device Installation

You may need to install a device or an additional module after the NIS-Elements main system installation.

- Go to [Start menu > Programs > NIS-Elements] program group.
- Select the [Modify Installation] command.
- Follow the install shield instructions. Check the checkboxes by the items you would like to add.
- Finish the installation.

1.1.5 Sample Database Installation

If you chose to install the Sample Database, a new subdirectory "Databases" is created inside the NIS-Elements installation directory (e.g. C:\Program files\NIS-Elements\Databases\...). The "Sample_Database.mdb" file is copied to there along with database images (stored in subdirectories). An administrator username/password to access this database is set to:

- Username: "sa"
- Password: "sa"
1.1.6 The software Copy Protection

The NIS-Elements software is delivered with a HASP hardware key.

The HASP key contains information about the software license and allows users to run the corresponding software. Please connect the USB HASP after NIS-Elements installation. The utility called "HASPinfo" is installed to the NIS-Elements directory. It enables the user to view information about the software license and is accessible via the [Help > HASP Info] menu command.
1.2 Command Line Options

When starting NIS-Elements from the command line (or when editing the desktop shortcut properties) you may take advantage of using the following parameters:

1.2.1 Syntax and Example

executable [switch1] [parameter1] [switch2] [parameter2]
['C:\Program Files\NIS-Elements\NIS D.exe" -f "C:\Images\starting_image.jp2"

This example command runs NIS-Elements and opens the [starting_image.jp2] at the beginning. By default, only one instance of the application is allowed to run. When the application is running, the command will be applied to this running instance (if the -q switch is not engaged). Some switches do not have parameters.

1.2.2 Switches

-?
Displays a help screen with the following content.

-c [Command]
The application runs an internal NIS-Elements command.

-f [Filename]
The application tries to open an image pointed to by [Filename].

-g [Grabber name]
The image grabber (driver) of the specified Grabber name will be used. No dialog box is displayed. As the name of the grabber, you can use the name which appears in the startup driver selection dialog, or the name of the driver class. These are listed in Windows registry (HKEY_CURRENT_USER):
"Software\Laboratory Imaging\Platform\Platform.INI\CLxGenericProviderGrabber"

-gn
No grabber driver will be loaded.
-h [HW Unit Name]
The specified HW Unit will be used. Two HW Units (e.g. two DS-U2 cameras) can be run by one driver. The available HW Units are listed in the [Acquire > Select Camera] dialog window. When using this option you must also use the [-c] switch. If you do not, the application will use the one selected the last time.

-i [Config Name]
The application creates a registry entry in "Laboratory Imaging\Platform\Config Name" to load from and save its configuration to.

-l [Language]
The application will run in the specified language. Us codes for the names of countries according to the ISO 3166-1 standard.

-m [Macro File]
Application will execute the macro file (*.mac) pointed to by [Macro File].

-p [Command]
The application window will be placed according to the parameter:
When [Command] is:
- [left] - the window is placed on the left monitor.
- [right] - the window is placed on the right monitor.
- [top] - the window is placed on the top monitor.
- [bottom] - the window is placed on the bottom monitor.
- [monitor N] - the window is placed on the Nth monitor.
- [rectangle (x0,y0,x1,y1)] - the window is placed in the specified rectangle (in workspace coordinates). The coordinates must be in parenthesis without any spaces.

-q
A new instance of the application is created.
The following items appear on the screen:

- **The menu bar** containing pull-down menus with sets of commands.
- **Main toolbars (left and top)**
- **Document toolbars (right and top)** which enable to customize the view of each opened image individually. See their description in the [Document structure] chapter.
- **Docked control windows** - see more description of docking windows in the [Modifying Layout] chapter.
- **The status bar** displaying useful information.
Horizontal Toolbar

[File > Open] invokes the open dialog window.

[File > Save] saves changes in the current document.

[File > Open/Save Next > Save Next] saves the current image as a new one according to the [File > Open/Save Next > Save Next Options].

[File > Print] invokes the [Print] dialog window with a print preview.

[Edit > Undo] moves one step back within the history of performed commands.

[Edit > Redo] moves one step forward within the history of performed commands.


[Z Stack Live] displays the live signal from camera while moving the active Z drive according to the [View > Acquisition Controls > Z Series] window settings.

[Integrate] turns the frames integration ON. Number of frames to be merged can be selected from a pull-down menu.

[Average] turns the frames averaging ON. Number of frames to count the average from can be selected from a pull-down menu.

[Acquire > Background Correction > Background Correction ON] applies the background correction, if it was defined.

[Calibration > Optical Configurations] displays the [optical configurations] manager.

[Calibration > New Optical Configuration] runs the optical configuration wizard for creating a new optical configuration.

[Customize] - on the right side, there is a tool bar where shortcuts to any of the control windows can be placed. Click the [Customize] button and (un)select control windows to be displayed or hidden.

Vertical Toolbar

[Pointing Tool] is a default cursor which enables to move the image when zoomed in.
[Magnifier Glass] is an interactive magnifier tool for examining image details.

[View > Analysis Controls > Annotations and Measurement] opens a control window with annotations and interactive measurement tools.

[View > Analysis Controls > Binary Toolbar] opens a control window with binary layer modification tools.

[Acquire > Capture Time Lapse] automatically/manually opens the ND2 capturing dialog window.

[Acquire > Capture Z Series] automatically/manually opens the ND2 capturing dialog window.

[Acquire > Capture Multipoint] automatically/manually opens the ND2 capturing dialog window.

[Edit > Copy] copies the current image to memory.

[Edit > Paste As New Image] creates a new document and inserts the image from memory.

[Image > Crop] is a tool for cropping images.

[Macro > Run Macro] runs the active macro.

[Window > Close All] closes all opened documents.

[Edit > General Options] displays the general options dialog window.

[View > Customize Toolbar > Setup] enables to add/remove buttons to the left toolbar.

### Status Bar

The status bar at the bottom shows the following information (from left to right): available views, a type of selected camera, the last performed command, the active objective name, and current coordinates of stage and Z-drive (if connected).
2.2 Modifying Layout

Having a well organized application layout can help you make the work with NIS-Elements very effective. The live image, captured images, various control windows (Camera Settings, Measurement, Histogram, LUTs, etc.) can be arranged within the application window. The control windows can be floating or docked inside one of the four docking panes. Connecting of a secondary monitor is also supported. User commands may be added to the main menu, and some tool bar buttons may be added/removed.

2.2.1 Layout Manager

A layout in the context of NIS-Elements is a set of options describing the arrangement of control windows, toolbars, and the menu items. The application can operate in two modes: supporting layouts or not. To switch the layouts mode ON/OFF, reach the [Edit > General Options] command and go for the [Appearance] section. There is a check box that enables/disables the mode. Once all layouts are defined, you can make them read-only by selecting another check box.

Blue tabs representing active layouts appear in the bottom left corner if layouts are enabled. The [Full Screen] and [Docked Controls] layouts are placed there by default. Other layouts can be added and managed via the Layout Manager.

If the "Read Only Layouts" box is checked, no layout changes are saved during work or on exit.

To Create a New Layout

- Modify the current layout to suit your concept of work.
- The asterisk appears next to the layout name (to indicate it has been modified).
- Right click the layout tab and select the [Save Current Layout As] command.
- Write the new layout name and confirm it by OK.
- A new tab appears and the layout is saved to the list of layouts.

If you do not need to create a new layout but would like to save the changes made, just right click the current tab (asterisk-signed) and select the [Save] command from the menu.
To Reload Previous Layout Settings

Unwanted changes of the layout may be made. Mostly, it can be fixed by the [Reload] command.

- Right click the asterisk-signed (recently modified but not saved) tab and choose the [Reload] command.
- The application restores the last saved state of the layout.

2.2.2 Layout Setup

Right click any layout tab and select the [Layout Manager] command. The Layout Manager appears.

List of Layouts

The list of currently available layouts is placed on the left side of the layout manager. Each layout may contain information about the controls, tool bars, menu, and commands to be performed when switching between layouts. Check the nearby boxes to select the type of information to be included. The check marks left of the layout names indicate the layout visibility (displayed/hidden).

- The [New] button adds a new layout to the list of layouts.
- The [Remove] button deletes the selected layout. The first two layouts cannot be deleted.
- The [Activate] button makes the selected layout active (current)
- The [Load Default] button has the same functionality as the Reload command described above. Except when applied to the Full Screen and the Docked Controls layouts where it loads the original settings - so they look just the same as after the program installation.
- The [Apply to All] button ensures that the executed changes will be applied to all layouts.
The [Import] button enables to load a previously saved set of layouts from an XML file.

The settings of all layouts can be saved to an external XML file. Use the [Export] button and define the destination file name.

Controls, Toolbars, Menu, and Commands of each layout settings may be modified in the right part of the Layout Manager. Just select the appropriate name:

**Controls**

The layout of docking panes and the control windows arrangement can be modified in this section of the dialog window. There are the following tools and a preview of the layout available.

If you use two monitors, select which screen to set up (primary display, secondary display) in the [Display] pull-down menu.

- These icons turn the docking panes ON/OFF. The currently selected docking pane is highlighted by blue color. The splitting is indicated by the dashed line.

- Each docking pane can be divided into halves by a splitting line. This button turns the splitting ON/OFF.

- If a two-monitor workstation is installed, this icon button allows you to select the content of the secondary image area of NIS-Elements. The pull-down menu contains the following options:
  - [Docking View - Horizontal Alignment] - the docked control windows will be arranged one below each other.
  - [Docking View - Vertical Alignment] - the docked control windows will be arranged on overlay.
  - [Live Window] - places the Live image to the secondary screen, and forces all non live windows to open in the primary screen.
These buttons perform the [Shrink] and [Expand] commands on the selected docking pane. A docking pane can be selected by clicking into the preview window.

**Arranging the Control Windows**

- Select one of the docking panes by clicking into the layout preview above the [Docker Controls] section.
- Select the tab you would like to add a control window to.
- Click the [Add] button and select the control window to be added from the pull-down menu.
- The control windows can be moved up and down within one tab by the arrow buttons.
- The [Remove] button deletes the selected control window from the docking pane. *There is always one empty tab at the end of the list. When you add a control window to it, another empty one will be created. It does not appear in the application screen.*

**Toolbars**

- Choose one of the toolbars from the [Toolbar] pull-down menu.
- Any button of the chosen toolbar may be hidden by deselecting the nearby check box.
- The [Large Buttons] option switch between two sizes of icons. The setting is shared by all toolbars.
- The selected toolbar may be hidden by deselecting the [Show toolbar] check box.
- The [Default] button discards changes and sets the default setting of the selected toolbar.

**Main Left Toolbar**

Being the most utilized toolbar of all, custom user buttons can be added to it. You can define your own buttons which run application functions or execute macros. Select the [Main Left Toolbar] from the pull-down menu.
Chapter 2  Application Appearance

Let's say that we very often use the [Binary > Close] command. It is useful to add a button providing a shortcut to it to the toolbar. Press the [Add] button, and choose [Command] from the context menu:

A new command (Command0) is added to the buttons list. Now, attach the NIS-Elements command: Open the pull-down menu on the right side of the [Command] edit box and click on the [Command List]. Choose the command from the list (e.g.: _CloseBinary) and confirm the selection by [OK]. It is possible to create a sequence of commands, by repeating the procedure.

If you are not satisfied with the default icon, you can change it by pressing the [Change] button. A dialog window for selecting the icon appears. You can select NIS-Elements icons by default, or load some others from files containing icons (ico, dll, ...). You can define icon for the command in a disabled state, too.

It is handy to define a tooltip (a text that appears when placing a mouse cursor over the icon) for your command. Simply write the text into the [Tooltip] box. You can change the position of the command in toolbar by using the arrows located under the [Add] and [Remove] buttons.

Menu

The Main Menu and the Picture Context Menu may be modified. Items of the Picture Context Menu (the menu which appears after you right click to an image) can be hidden by unchecking check boxes similarly to most of the tool bars.
Modifying the Main Menu

- Select the [Main Menu] in the topmost pull-down menu.
- Any item may be added to the main menu - separator, Menu Command, a submenu (Menu Popup), and even a new menu (Main Menu Popup) - by the [Add] button.
- Select the existing menu item you would like to place the new item under.
- Click the [Add] button and select the item type from the pull-down menu.
- Edit the [Item Properties]. The [Default] button discards all changes and loads the main menu original configuration. The [Remove] button deletes the selected item. The arrow buttons move the selected item up/down.

Item Properties

- [Text] - This is the text which appears in the pull-down menu. You may place the "&" sign before any letter. Such letter will be considered a shortcut key when browsing the menu.
- [Hot key] - one or more hot key shortcuts may be assigned to the command. Just press the [Add] button and press the key combination. The [Remove] button removes the selected hot key.
- [Enabled/Disabled bitmap, Command] - These fields serve for assigning a bitmap image and a NIS-Elements function to the menu command. It works in the same way as when modifying the Main Left Toolbar (described above).

Commands

These settings enable to run a command or a macro right before and after you switch to the layout. Insert the commands similarly as it is described above.
2.2.3 Docking Panes without Using the Layout Manager

Docking panes are empty square spaces inside the application window, where you can place ("dock") the control windows. They can help to keep the screen "tidy". There is one docking pane available on each side (Top, Right, Bottom, Left) and can be further divided into halves.

**To Display a Docking Pane**

- Go to the [View > Docking Panes] submenu and select the pane you would like to display.
- The docking pane appears, either empty or with some window(s) docked.
- Repeat this task to display more panes.

*The same submenu can be also displayed by right-clicking into the empty application screen.*

- To divide a docking pane, right click inside the docking pane and select the [Split Docker] command.

**To Hide a Docking Pane**

Either click the arrows in the top left corner, or double click (or Ctrl + click) the empty pane (not the docked control window). The pane minimizes to a stripe by the edge of the application. It can be recalled to its original size by double clicking it.
If you would like to close the pane completely, minimize it and press the cross button, or you can right click the pane and unselect the [Docking View] option.

**To Shrink/Expand Docking Panes**

Having more docking panes opened, a situation where there is not enough room for the control windows can occur. In that case, the Shrink and Expand commands shall be used.

- Right click the pane you would like to shrink/expand.
- A context menu appears.
- Select the Expand/Shrink command.

*The commands Shrink/Expand Top, Right, Bottom, Left are available. When one of the panes shrinks, the neighbouring pane expands to the emptied corner and vice-versa.*

**2.2.4 Control Windows**

The following control windows can be displayed within the application screen. They can be floating, or docked inside the horizontal or vertical docking panes:

**Acquisition**
- AVI Acquisition
- Auto Capture Folder
- Camera Settings*
- Filters and Shutters*
- Lamp*
- Nosepiece*
- Microscope Control Pad*
- XYZ Navigation

**Visualization**
- Binary Layers*
- Histogram
- LUTs
- Opened Images
- Preview
- XY Overview*

**Analysis**
- Annotations and Measurements
- Automated Measurement*
- Automated Measurement Results*
- Binary Toolbar*
- EDF Z-Profile*
- Intensity Profile
- Object Count*
- Pixel Classifier*
- Thresholding*

**Macro**
- Debug View
- Variables
* - this control window is optional. An additional software module or a correct device connected is required in order to display it.

To Display a Control Window

- Go to the [View] menu and select the desired control window. The controls are sorted to four groups: Acquisition, Analysis, Macro, Visualisation controls.
- The control window appears floating on the screen.
- To dock (and undock) it, double click its caption.

*It is also possible to display a control window docked. Right click inside a docking pane and select the one of your choice from the context menu. If the window is already opened somewhere (e.g. in the opposite pane or floating), it closes and moves to the new destination.*

To Close a Control Window

- Click the "cross" button on the right side of the active window caption.
- If the window is docked, you can also right click its caption and uncheck the appropriate window.
- The control window closes.

Tab or Caption Style?

More control windows can be docked in the same place while only the front one is being visible. There are two styles of displaying these windows, Tab and Caption.

Tab Style

- Besides the current control window, the other window tabs are visible.
- Switching the windows is a one click operation.
Caption Style

- All docked windows except the current one are hidden.
- The switching and undocking of windows is done via the menu that appears when you click the arrow button.
### 2.3 Organizer

Apart from the main application mode used for capturing and image analysis, NIS-Elements provides a special [Organizer] mode.

Organizer was designed to ease the work with image files and databases. To activate organizer, click the [Organizer] button located in the top right corner of the application window or press [F10].

The screen is primarily divided into two identical panes, each pane switchable between two modes: the [Files] mode and the [Database] mode. To switch from one pane to the other one use the [View > Next Pane] command. To copy files between the panes, simply drag the images from one side to the other side.

- **Files** - This button switches the pane to show a directory tree and images from the selected folder (and optionally its subfolders). It is called the [Files view].

- **Database** - This button switches the pane to show the database structure and lists images from the currently selected database table. This is called the [Database view].
Features Available in the Files View

This button toggles the display of the directory tree. You can switch it off to get additional space to display images.

In this pull-down menu it is possible to set the file type to be displayed. You can select a particular extension or show [All Images].

If this check-box is selected all images from the included subfolders are displayed.
Features Available in the Database View

This button displays the detailed information about the selected image. You can switch it off to get additional space to display images.

This pull-down menu displays the active connection point and enables to switch between connected databases.

This pull-down menu selects the active database table.

2.3.1 Image Filter

Both views (Files and Database) have the option to define a filter. It enables you to display only images which fit the defined conditions (one or two).

This button activates the filter.

Pressing this button invokes the filter setup dialog box.

Basic Mode

This mode enables you to view files that match one defined condition.
Advanced Mode

This mode enables you to define two conditions with a relationship defined between them. Either select [OR] to display files matching at least one condition, or select [AND] to display files which match both conditions.

First, select the field, where NIS-Elements should search for a given expression. When using a filter in the [Files] view, there are fields from file properties listed. In the Database view, the listbox shows the names of fields from the currently selected database table.

If the selected field is of a numerical type (e.g. Size, Calibration, File date etc.) you can specify, whether you want to find the exact value or a value in a given range. This is selected by the [Condition type] radio button.

If the field type is [Text], the [Occurrence] setting determines the way of evaluating the expression:

- [Anywhere] - If a given sequence of characters is found anywhere in the sequence of characters in the field, the system will evaluate it as a match. Example: you have entered "set" to the [Values] field. The filter will select records with the following field values: set, reset, settings, preset, etc.

- [Exact] - If the given sequence of characters exactly equals to the content of the field, it is evaluated as a match. Example: if "set" is entered, fields containing the set value will match only.

- [Start] - If the entered string is found at the beginning of a field, it is displayed by filter. Example: If "set" is entered, fields containing set, settings, setup are selected.
• [All letter strings] - It is possible to search for more expressions. These should be entered separated by commas. If you want to enter an expression with a space, insert it into quotes. If this option is selected, only records in whose fields all of those expressions appear (anywhere) are selected.

• [Any letter string] - This option is for entering multiple expressions as above, but this time every field with an occurrence of at least one from the given expressions is matched.

### 2.3.2 Operations with Images

- To open an image from the [Files] view, double click its thumbnail. NIS-Elements will display it in the main window.

- To select multiple images, either click on the first and the last image holding the [Shift] key (continuous group selection) or click individual image names with the [Ctrl] key down.

- You can copy one or more images from one folder to another by "drag and drop".

- This quick method can be used for inserting images to a database too. Simply drag the image from a folder and drop it onto the pane, where the database table is opened.

- To delete selected images press the [Delete] key.

All those operations and some other can be invoked also from the context menu, which appears each time you right click on the image thumbnail.
2.3.3 Thumbnail Displaying Options

You can adjust the way images are shown in the organizer. Press the [Show thumbnail view with...] button of the main tool bar and select the size of displayed image thumbnails. Selecting the [Details with preview] option will display one image below the other with all available information about it at the side.

There is a possibility to rotate images from within the organizer. It affects not only the image thumbnails, but the image data too. Press the corresponding buttons.

2.3.4 Ordering of Images

To order displayed images, right click anywhere in the pane - a context menu will appear. Move to the [Sort by] submenu which offers several ordering criteria. If the ordering is turned ON already, the icon is displayed on the left side of the applied criterion.
2.3.5 Grouping of Images

To arrange the view of images efficiently, you can use the capability of grouping of images. Drag the column name bar to the grouping bar (right above the column name bars). All files with matching field values of the selected column will be grouped together. This can be undone by dragging the column caption back. See the example on the Files View picture above (the Dimensions column is grouped).

2.3.6 Adjusting the Organizer Layout

The pane size is adjustable. To resize it move the mouse cursor to the dividing in line the middle. The cursor becomes an arrow with two tips. Press the mouse button and drag it left/right to the new position.

- Resizes the panes to achieve the same size for both of them.
- Resizes the pane to its maximal/minimal size (one pane is then displayed on the whole screen).
3 Setting the Hardware Up

3.1 Cameras

This chapter is dedicated particularly to users running the active version of NIS-Elements - equipped with a camera. Let's assume the camera works properly, is connected to the system with proper system drivers installed and running (if required by camera).

Selecting the Driver

You will be asked to select the camera driver everytime you launch NIS-Elements. You can change the driver later, using the [Acquire > Select Driver] command. Choose the driver that matches your camera:

![Driver Selection]

Selecting the Camera

Color cameras can be used in a monochromatic mode. The actual camera type (color/mono) can be selected by the [Acquire > Select Camera] command. Confirm the choice with [OK].
Setting Up the Camera

Exposure time, camera resolution, and other camera-specific features are adjustable from the [Camera Settings] window. To invoke it, use the [Acquire > Camera Settings] command.

Live Signal from Camera

This button opens a new document window with the Live-Fast image from camera. New buttons for controlling the camera appear in the document window to control the camera.

Live Formats

A camera format is a set of attributes of a video signal such as: resolution, bit depth, frame rate etc. The live signal is a stream of image data, coming from the camera to your computer in real time. NIS-Elements provides two different camera modes: [Fast] and [Quality], each serving a different purpose. The format of both modes can be set within the [Camera Settings] control window.

Live - Fast

This tool bar button runs the [Fast] live mode. This mode is usually set to low resolution, therefore the framerate is high. It is used for searching the observed specimen or when focusing manually.

Capture - Quality

This tool bar button runs the [Quality] live mode. This mode should be set to high resolution which reduces the camera framerate. It is applied every time the [Capture] button is pressed.
Capturing Images

Although it is possible to perform some procedures directly on the live image, other image operations require [captured] or [frozen] images. If you try to perform such operation when the live image is active, NIS-Elements automatically freezes the image. Let's see the difference between the [Capture] and the [Freeze] commands:

This is the [Capture] button. When pressed, the camera exposure runs till the end, and the next frame is captured and displayed on the screen. In fact, it is the first frame with the complete exposure after you have pressed the [Capture] button.

The [Freeze] button interrupts the camera exposure, and displays the very last complete frame.

If you are using the [Fast] mode and press [Capture], NIS-Elements will automatically switch to the quality mode to capture the image. When the image is captured, it is opened on the screen as a new document.
3.2 Configuring Attached Hardware

Typically, laboratory computer image analysis systems consist of a computer, a camera, and a microscope equipped with all necessary accessories (objectives, filters, shutters, light, rotary changers, etc). Most of the mentioned microscopic hardware is often motorized and therefore can be controlled by NIS-Elements. Thanks to the NIS-Elements concept, it is possible to integrate single settings of all these devices into one compact set called an [Optical Configuration]. It is recommended to create several optical configurations containing particular devices settings. Then a single click can completely change the hardware configuration.

3.2.1 Creating New Optical Configuration

Please check that all the devices (microscopes, cameras, etc.) that you want to associate with the new optical configuration are properly attached to the system and working. Insert a calibration slide to the microscope.

Start the Optical Configuration Wizard

Choose the [Calibration > New Optical Configuration] command from the Calibration menu. The Optical Configuration Wizard appears and the camera is automatically set to Live mode.
• Type the name of the optical configuration. We recommend to use short descriptive names, e.g. the name of the associated objective.
• Select whether to associate an objective, a camera or a microscope.
• Use the [Camera Setup] button to adjust the camera settings.
• You can start the illumination correction process by pressing the [Capture Correction Image] button.
• Adjust the Microscope settings using the [Microscope Pad] and select which parts of the microscope shall be included in the configuration by checking them in the [Options] dialog box.
• If there is more than one shutter and you would like to associate a shutter with the optical configuration, select which one is the [Active Shutter] from the pull-down menu.

Press the [Finish] button (if the Objective was not selected) or the [Next] button to continue...

**Selecting Objective**

![Optical configuration wizard]

Now, please select one of the following alternatives:
• Select one of the already defined objectives from the pull-down menu or insert one of the predefined objectives via the [Insert] button.
• Or, you can create a new objective by filling its name to the [Create new objective] edit box.

Press the [Next] button to continue...
Objective Calibration

All digitized images consist of a number of rectangular elements called pixels. A calibration assigns real size to one pixel, so that correct and realistic measurements can be performed. It is necessary to create a calibration for each objective because it is bound to the objective magnification. It is possible to assign names to objective calibrations and to store them.

Select one of the following alternatives:

- The [Manual] calibration lets you draw a line into a picture and define its real length (see below). The "On Captured" check box allows you to decide whether live or captured image is used for the calibration.
- Having a motorized microscope, there are the [Auto] and [4 points] alternatives available.
- Skip the calibration, if the selected objective (selected in the previous step) has been calibrated already.

Press the [Next] button to continue...

Manual Calibration

This step is dedicated to the manual calibration.

- The distance is defined by placing lines (Horizontal, Vertical, Parallel) to the image. Choose the orientation of the lines, then click into the image to place the first line.
Place the second line in the intended position by another click. You can modify the line position while holding the mouse button, not later.

- When "Parallel lines" are selected, at first, define the beginning of the first line. The next click defines its orientation and length. When satisfied, finish the first line creation by right-click. The second line can be placed by another click to the image, this time only to adjust the distance from the first line. The process is completed by right-click.

The following dialog box appears...

![Manual calibration](image)

- Now enter the distance between the two lines and select correct units. Press the [OK] button to continue...

**Automatic Calibration (the Auto method)**

This method is fully automatic. NIS-Elements moves the motorized stage, acquires two images, and calculates the calibration from the shift of the images.

**Automatic Calibration (4 points method)**

The system draws four points on the screen (subsequently) and asks user to move some significant part of the specimen to match the points. After all four steps are completed, the calibration is calculated from the moves of the stage.
Optical Configuration Completion

The last status window informs you about the parameters of the optical configuration. Click [Finish] to complete the process.

- You can create more calibrations by repeating the above procedures.
- The calibrations are saved to registry immediately and can be exported to an XML file ([Calibration > Optical Configurations > Backup]).
- The selected calibration is maintained. It is applied during any image input from the camera.
- The selected calibration remains unchanged even if an image containing a (different) calibration would be loaded. The different calibration is applied to the actions regarding the loaded image only.
- It is possible to adjust the created calibration. Select the [Calibration > Optical Configurations] command.
3.2.2 Managing Optical Configurations

To display the optical configurations manager, run the [Calibration > Optical Configurations] command. You can make the following actions from the dialog window:

- Create, duplicate, rename, delete, and switch between the optical configurations.
- Add, create new, edit, duplicate, delete, and calibrate objectives.
- Import and export optical configurations and the set of objectives to/from an XML file.

**Optical Configurations**

Once created, the configuration appears in the list and can be shared with other users by changing the [Private] option to [Shared]*. The following settings of a selected optical configuration can be adjusted:

- It can be deleted by pressing the [Remove] button. A confirmation dialog box appears.
- Its name can be changed by the [Rename] button. The configuration name appears in the main toolbar (if the [Show on toolbar] option is checked).
- A copy of the configuration can be made via the [Duplicate] button.
- It can be turned ON by the [Set As Active] button.
- Settings of all configurations can be exported to an external XML file using the [Backup] button.
- The previously exported optical configurations settings can be loaded from an XML file via the [Restore] button.
- The list can be ordered manually via the nearby arrow buttons.
- Each configuration can be arbitrary modified within the [Details] section of the optical configurations window.

* Please see the [User Management] chapter for details.

**Details**

The [Details] section enables you to completely modify the selected optical configuration. Select whether to include the objective, camera settings, microscope setting, and one of the shutters from the [Active Shutter] pull-down menu.

Buttons representing optical configurations are placed on the main toolbar by default. You can remove the button of the currently selected configuration by unchecking the [Show on toolbar] box.
### 3.2.3 Objectives and Calibrations

- All images captured while a calibrated optical configuration has been selected are calibrated automatically.
- If you need to change image calibration or you want to calibrate the image acquired via scanner or transferred from a digital camera, use the [Calibration > Recalibrate Document] command.
- If there is no calibrated optical configuration, the simplest way to create it is to invoke the [Calibration > Quick Calibration] command. It creates a new optical configuration containing a calibrated objective.
- Calibration of the currently selected (active) objective can be modified via the [Calibration > Recalibrate Objective] command. The calibration procedure is described above.
- The active objective name is displayed on the application status bar. Double click it to invoke the optical configurations settings dialog window.

#### Objectives

A list of often used objectives can be created within the Optical Configurations dialog window. Any objective can be associated with one or more optical configurations. Use the following buttons to manage the objectives:

- [Insert] - click the button and select one of the predefined objectives from the pull-down menu (it is ordered by the objectives magnification).
- Use the [New] button to create a custom objective. A wizard will lead you through the calibration process.
- The [Edit] button displays a dialog window where it is possible to adjust the objective properties, calibration, etc. The name, working distance, numerical aperture, and the refractive index values of the predefined objectives cannot be changed.
- If zoom is used, the objective calibration must be re-counted accordingly. Use the [Duplicate] button to make a copy of an objective and define the zoom factor in the dialog window which opens.
- The [Remove] button deletes the selected objective.
- The [Recalibrate] button starts the calibration of the selected objective. Please see [Objective Calibration] above.
- The [Backup] button enables you to export the complete list of objectives to an XML file. The standard [Save As] dialog window appears.
• The [Restore] button enables you to import a complete list of objectives from an external XML file previously created by the [Backup] command.
• The [Current unit] button invokes a pull-down menu where units for the whole application can be selected.
• The [Create config. from objective] uses the currently selected objective to create a new optical configuration. Just fill in the configuration name when asked.

### 3.2.4 Units

NIS-Elements supports the following units: pixels, nanometers, micrometers, millimeters, centimeters, decimeters, meters, kilometers, inches, and mils. If the image is uncalibrated, pixels are the only units available. In case of a calibrated image, it is possible to select other units. All values (e.g. measured length/area) are then displayed in the selected units. There are two ways how to select the desired units:

• Right click the [status bar] of the document window where the calibration is displayed. Select the units and precision of their display.
• Or, click the [Current unit] button located in the [Optical configurations] dialog window and select the units.
3.3 User Management

NIS-Elements user rights management utilizes MS Windows user accounts. Different user rights to some NIS-Elements features can be assigned to three user groups:
- Admin
- Common
- Guest

Run the [Edit > General Options] command and select [Users] in the left column, the following dialog window appears:

Let's explain the user rights on the example of layouts: Layout settings can be stored in two places (storages): private or shared. When you create a new layout, it is set as [private] automatically and saved to your windows account profile. Nobody else can ever use or change the private layout. However, you can decide to share the layout with other users and set it [shared] (within the layout manager). All users can utilize the shared items, but only members of a group with permission to modify them can do so.
Export/Import
These buttons enable anyone to save/load complete settings of users and user groups to/from an external XML file. Standard [Open] and [Save As] dialog windows appear. Having the data exported may be useful when copying the settings to other computers.

Enumerate All Windows Users
This button starts copying MS Windows accounts to NIS-Elements. The accounts are assigned to user groups (admin, common, guest) according to their Windows permission settings

3.3.1 Group Settings
Select the group you would like to modify permissions of from the [Group] pull-down menu. You have to have the [Modify users] permission to do that.

Modify users
Users can modify permissions of all groups in this dialog window, and apply the [Set active camera as shared] and the [Set installed devices as shared] buttons.

Modify shared objectives
This option enables user to delete, recalibrate, etc. objectives within the [Calibration > Optical Configurations] dialog window.

Modify shared optical configurations
This option enables user to modify existing optical configurations in the [Calibration > Optical Configurations] dialog window.

Modify shared layouts
This option enables user to modify shared layouts in [View > Layout > Layout Manager] dialog window.

Modify shared macros
This option enables user to manage shared macros via the [Macro > Manage Shared Macros] command.
Modify shared reports
This option enables user to manage shared reports via the [File > Manage Shared Reports] command.

Select camera
Users with this permission can select any camera driver from the [Acquire > Select Driver] dialog window. Otherwise they are forced to use the current shared camera (below).

Modify devices
Users with this permission can add/remove/modify devices within the [Devices > Manage Devices] dialog window.

Set active camera as shared
This button sets the currently selected camera as default for all users without the [Select camera] permission.

Set installed devices as shared
This option sets all devices currently listed in the [Devices > Manage Devices] dialog window as shared, which means that other user will be able to use them. If there was a list of shared devices before, it is overwritten by the new list.

3.3.2 Defaults for this Page
Restores the default setting for User Rights Options.
4 Capturing Images

4.1 Images Capturing

Having all hardware accessories set up and NIS-Elements installed, you can start capturing images. The easiest way is to capture a single image. There are also several other ways of acquiring images, some of them specialized needing a specific hardware. They are described in the subsequent chapters.

4.1.1 Single Image Capture

- Turn the connected camera and other devices ON and start NIS-Elements. Select the corresponding camera driver.
- When the application is started display the Camera Settings control window - [View > Acquisition Controls > Camera Settings].
- Switch camera to live mode - [Acquire > Live Fast] - and adjust its parameters to get the live image clear.
- Focus the objective on the scene you would like to capture the image of.
- Switch to the [Live - Quality] mode and adjust its settings, especially the [Exposure time] and [Format] (this mode will be used every time an image is captured).
- Switch back to the [Live - Fast] mode. It is the usual mode for smooth work because less of the hardware resources are engaged.
- Capture the image by pressing the capture button on the horizontal toolbar, by invoking the [Acquire > Capture] command, or using the [Ctrl + -] shortcut.
- A new image is opened and named "Captured" automatically.
4.2 Time Lapse Acquisition

Detailed studying of long-lasting processes is enabled by the time lapse acquisition mode of NIS-Elements. The possible experiment duration is almost limitless. Invoke the [Acquire > Capture Time Lapse] command to set the experiment up:

![Capture Timelapse window](image)

4.2.1 Time Schedule

[The Time schedule] table enables you to define one time phase where duration, interval between single images, and number of images of the phase can be adjusted for each phase. The Interval, Duration, and Loops settings are bound together, so you just need to set two of these parameters. The remaining parameter is calculated automatically. Only the checked time phases will be captured.

4.2.2 Auto Focus

Automatic focusing can be used during experiment. You can select the autofocus method that best meets your needs from the pull-down menu. The next pull-down menu
determines whether the focusing shall be performed at the beginning of the whole experiment or at the beginning of each time-phase. The [Define] button shows a dialog window where you can define parameters of the selected focusing method.

### 4.2.3 Special Options

The shutter can be closed between the acquisitions. Just check the [Close active Shutter...] box.

You have an option to run a command* (or a macro) before and after the each image acquisition. It is possible to type the command directly, or press the rightmost button to show the context menu, where you can select a command from the [Command List], or search for macro files on a disk ([Run Macro]).

* - The `Live();` command can be used often. However, in some exceptional circumstances the `Live();` command may not work properly. In such case, please, use the `LiveNoMsgLoop();` command instead.
4.3 Multipoint Acquisition

This feature is available when a motorized XY(Z) stage is present in the system and connected properly. An arbitrary array of XY(Z) positions can be defined to be scanned during a multipoint capture experiment. The Z position can be included optionally. The defined array can be saved (and loaded later) to an XML file by the [Save] button. Invoke the [Acquire > Capture Multipoint] command.

![Multipoint Acquisition Interface](image)
4.3.1 To Define a Multipoint Array

- Move the stage to the first point (via joystick or the "Move" command).
- Press the [Add New] button. The new line containing current coordinates appears in the list.
- Move to the next position and repeat the steps until you have all the intended points defined.

4.3.2 To Change a Single Z Coordinate

- Click inside the line you would like to change.
- Move the Z drive to the new position.
- Click the [<->] button.

*The XY coordinates of one point cannot be adjusted (unless you delete one and add a new point).*

4.3.3 Offset All

This button appears next to the currently selected point. It can shift the XY coordinates of all points in the same way:

- Select one point of the list. (The stage moves to its coordinates automatically)
- Move the XY(Z) stage to a new position (define the offset).
- Press the [Offset All] button.
- The coordinates of all points are overwritten (The same shift as you made with the stage is added/subtracted).

4.3.4 Special Options

If the [Optimize] button is pressed, the system will re-order the defined points in order to minimize the XY stage trajectory.

A grid of points aimed to be used for scanning well-plates can be defined using the [Custom] button.

The shutter can be closed between the acquisitions. Just check the [Close active Shutter...] box.

Automatic focusing can be used during the experiment. You can select the autofocus method that best meets your needs from the pull-down menu. The [Define] button
shows a dialog window where you can define parameters of the selected focusing method (depending on your stage equipment and hardware drivers).
You have an option to run a command* (or a macro) before and after the each image acquisition. It is possible to type the command directly, or press the rightmost button to show the context menu, where you can select a command from the [Command List], or search for macro files on a disk ([Run Macro]).

* - The [Live();] command can be used often. However, in some exceptional circumstances the Live(); command may not work properly. In such case, please use the [LiveNoMsgLoop();] command instead.
4.4 Z Series Acquisition

Capturing images from different focal planes of the specimen can be performed using the [Acquire > Capture Z Series > Capture Automatically] command.

This dialog serves for setting the method of capturing in Z Series. There are the following ways of defining the Z drive range:

4.4.1 Top/Bottom Position, Step

Press this button, the cube turns blue. The range is defined by the top and the bottom position:

- Run the Live camera signal, then select a [Z device] (in case you have more than one connected) from the pull-down menu.
- Set the Z range: move the Z drive to the top position and press the [Top] button, move it to the bottom position and press the [Bottom] button.
- Define the [Step] size in µm or the number of [steps] to be captured.
- For Top/Bottom Position mode, the [Home position] is assigned to the middle one of all the defined steps (e.g. for 5 steps, it is third step, etc.).
4.4.2  Home Position, Range

Press one of the following buttons, the cube turns yellow. The range is defined by the home-position and the scanning range:

- **Symmetric mode** Define the [Range] by inserting a value in μm.
- **Asymmetric mode** The range is specified by two values, [Below] - the distance below home position, and [Above] - the distance above home position.

- Run the Live camera signal, select the [Z device] (in case you have more than one connected) from the pull-down menu.
- Move the Z drive to the position which you would like the Z drive to move around. Press the [Home] button to define the home position.
- Specify the scanning [Range].
- Define the [Step] size in um or the number of [steps] to be captured.

4.4.3  Special Options

The [Reset] button discards the Top, Home, and Bottom positions settings.

4.4.4  Home and All Position

When capturing Z and Lambda experiments, the Z phase option specifies how the lambda acquisition will be treated. Lambda period with option “all” will be taken for all z-steps. On the contrary, lambda period with option “home” will be taken only for home position.
4.5 AVI Acquisition

AVI acquisition is an easy way of recording actions in real time. It produces *.avi video files, which can be played by any standard video player, so you do not need NIS-Elements to view the results.

4.5.1 Capturing AVI movie

- Display the AVI Acquisition control window by the [View > Controls > AVI Acquisition] command.
- Adjust the advanced settings, especially define the file name and the destination folder.
- Click the [Record] button. The live image appears inside the application window and is being recorded according to the settings.
- Stop recording by the [Stop] button, or wait until the time defined in the [Duration] field passes.
- When stopped, the AVI file remains opened in a new document window.

Settings

Press the [Advanced] button to view the whole control window and set the following options:

Live

Choose the format of the camera. The Live-Fast or Capture-Quality mode settings will be used while capturing the AVI movie.

Rate

The number of frames per second of the movie can be defined. Possible values range from 1 to 50 fps. There is also the [Max Fps] option. When selected, the system captures every frame sent from a camera. If the frame rate is beyond hardware capabilities of your system,
some frames will be omitted.

**Duration**
Several predefined lengths of the movie may be selected (60 min, 10 min, 1 min, 10 s) or the [Infinite] option is available. When selected, the movie will be captured until the [Stop] button is pressed or the hard drive is filled to capacity.

**File - the path and the name**
Define the path to a directory and the file name of the AVI file. If you capture more than one movie without changing the file name setting, the other files will be numbered automatically.

**File - Codec**
It is common to encode (compress) movies in order to save some disk capacity. This can be done using various types of codecs. Press the [Open] button on the right and a dialog window appears. Select one of the codecs available in the system or use the [Default] option. Remember that the codec you choose must be available for the AVI playback.

*Video codec is a software tool which can [cod]e and [dec]ode video files. We recommend to use one of the following codecs (FPS - maximum camera framerate which can be handled, size - size of a reference 10s video, platform availability):*

- Cinepack: FPS-1.1; size-1.2 MB; availability: Windows XP + Mac
- Intel Indeo: FPS-5.9; size-1.7 MB; availability: Windows XP
- Microsoft YUV: FPS-14.3; size-172 MB; availability: Windows XP

**Size**
The size is determined by the resolution of the connected camera. However, the size may be adjusted by the following options:

- Original, 1/2 Original, 1/4 Original - sizes counted from the applied camera resolution
- NTSC TV, PAL TV - standard TV resolutions
- Free Size - an arbitrary [Width] and [Height] in pixels may be defined.

No matter what size is selected, the video always displays the whole scene. If the defined size has different aspect ratio than the live image, the empty space is filled with black.

**Maintain aspect ratio of**
If the [Free Size] option is selected, the aspect ratio may be defined. One of the width and height dimensions is then counted automatically.
5.1.1 Image Layers

Each NIS-Elements document can consist of the following image layers, serving different purposes:

**Annotation layer** - In this layer, graphical objects and texts can be stored in a vector format. The results of interactive and automatic measurements, arbitrary text notes and other annotations are stored there.

**Color layer** - Contains image data. When you open an image from disk, it is loaded to this layer. It can handle images with the depth of up to 16 bits per color component. The dimensions of this layer determine the view of the other layers.

*When saving an image, only the JPEG2000 and ND2 file format can handle all image layers and are capable of saving them. The other image formats will save the content of the color layer only.*

5.1.2 Document Types in NIS-Elements

**RGB documents**

Images acquired by a color camera typically consist of three components that represent red, green and blue channel intensities. Pixel values for each component range from 0 to 65535 (in 16 bit depth). You can display a single color channel using the tabs located in the bottom-left corner of a document window, or an arbitrary combination of them can be selected while holding the [Ctrl] key down.

![RGB tabs](image)

**Multi-channel documents**

These documents usually arise from fluorescence microscopy. Instead of 3 color components (R, G, B), multichannel images can be composed of many user-definable color planes. When a multichannel image is opened, the channel panes in the bottom-left corner are not the standard ones (Red, Green, Blue), but are named differently according to the channel colors. The maximum number of channels is 32.

*If there is a document that contains more than 8 components, the tabs are replaced by the wavelength dimension, similarly to how the dimension loops of ND2 documents are displayed.*
ND2 (N dimensions) documents
The ND2 document is a set of images. There are four types of ND documents depending on the method of acquisition: [T] for timelapse acquisition, [XY] for multipoint acquisition, [Z] for Z-series (slices) acquisition and [Lambda] for acquisition of a defined wavelength (fluorescence imaging). All these methods can be combined together.

5.1.3 Document Window

When you open a document, the following buttons appear on the document window toolbar.
LUTs

[Enable LUTs] button applies LUTs to the image.

[Keep Auto Scale LUTs] button applies the AutoScale command to the image continuously.

[Auto Scale] button performs automatic setting of LUTs.

[Reset LUTs] button discards the LUTs settings.

Zoom Controls

[Fit to screen] button adjusts zoom to view the whole image within the NIS-Elements screen. It corresponds to the [View > Zoom > Fit to screen] command.

[Best Fit] button adjusts zoom to fit the NIS-Elements image window in one direction but to fill the screen. Corresponds to the [View > Zoom > Best Fit] command.

[1:1 Zoom] button adjust zoom so that one pixel of the image matches one pixel of monitor. It corresponds to the [View > Zoom > 1:1 Zoom] command.

[Zoom In] Increases magnification of the image. It corresponds to the [View > Zoom > Zoom In ] command.

[Zoom Out] Decreases magnification of the image. It corresponds to the [View > Zoom > Zoom Out] command.

General Controls

[Show Probe] button activates the probe. The probe affects histograms, auto exposure and auto white balance functions.

[Show Grid] button displays the grid for rough measurements.

[Show Scale] button displays the image scale.

[Show Profile] button displays the [View > Analysis Controls > Intensity Profile] control window. It allows you to specify a linear section in the image of which the pixel intensities graph will be created.
Right click the icons to invoke a context menu where properties of each tool can be modified.

**Status Bar**

The status bar at the bottom of the application window displays the following information (from left to right): image calibration, pixel coordinates of the mouse cursor along with channel intensities, color mode, bit depth, and picture size in pixels.

| 0.34 μm/px | (990, 997) RGB: [111, 111, 144] | RGB 8bit, 1280 x 1024 pixels |

**5.1.4 Working with Vector Objects**

There are two types of vector objects which can be placed over the image: annotation and measurement objects.

**Annotation Objects**

This button toggles viewing of the annotation objects (text notes, arrows, etc.). Right-clicking the button displays a context menu with the following options:

- [Clear All Objects] will delete annotation and measurement objects.
- [Select Annotation Objects] will select all objects that are not the measurement ones.
- [Clear Measurement Objects] will delete all measurement objects.
- [Select All Objects] and [Deselect] will select/deselect all annotation and measurement objects.

**Measurement Objects**

This button toggles viewing of the measurement objects of the interactive and automatic measurements. Right click it to display a context menu with the following options. The [Clear All Objects], [Select All Objects], and [Deselect] options work the same as described above. There are two different options:

- [Remove Automatic Measurement objects] will remove only objects created by automatic measurement.
- [Select Interactive Measurement objects] will select all measurement objects created by hand.
5.2 ND2 Files

A special document type consisting of one or more image sequences is a so-called ND (n-dimensional) document. N-dimensional experiments combine up to 5 acquisition types together: Z series, time-lapse, fluorescence (Lambda), multipoint, and large image. The resulting image sequence (*.nd2 file) includes information about the experiment structure and its progress.

5.2.1 Browsing ND2 Document

When an ND2 file is opened, its structure is pictured at the bottom of the document window. There is a time line with all captured images indicated by gray markers. The blue-highlighted marker indicates the currently observed image. Below the time line, there is one row of blue rectangles for each dimension. Blue rectangles stand for single phases of each experiment dimension. In case the multichannel dimension is included, the channels are indicated by the color tabs at the very bottom of the document window.

ND Control Bar

Browse the ND document by clicking inside the time line - single time phases are highlighted by the alternating red and blue background. You can also display a frame by selecting the corresponding blue rectangle. There are other ways how to observe the ND document using the following buttons:

Playing options

[Play Sequence] displays the selected/all images of the browsed dimension.

[Stop Playing] stops playing the sequence at the current frame.

[Previous Position] displays the previous frame of the browsed dimension.

[Next Position] displays the next image of the browsed dimension.

[Increase Playing Speed] - the speed ranges from 0.5 FPS to 500 FPS.
[Decrease Playing Speed] - the speed ranges from 0.5 FPS to 500 FPS.

[Real Time Playing Speed] sets the playing speed to real-time (as the document was captured).

[Maximum Playing Speed for Every Frame] sets the playing speed to maximum while the display of every frame is guaranteed (when the speed is set to maximum by the + button, some frames are usually omitted when playing the sequence depending on your graphic card).

[Home Position] displays the frame of the Z dimension that was set as "home" during the acquisition.

Right click the bar to display the context menu. Select the playing mode.

**Observing ND2 Data Sets**

There are two views available for observing ND2 data.

**Main View**

- When you open an ND2 file, it opens in this view.

**Slices View**

*Available for Z, T.* This view displays orthogonal XY, XZ, and YZ projections of the image sequence.
Examples:
5.3 Working with Documents

It is possible to work with multiple image documents opened at the same time. The Multi-Document Window Environment ensures that every document is opened to a single window that contains the most used controls affecting the image appearance (Layers, LUTs, Zoom etc.).

5.3.1 Opening Saved Files

NIS-Elements offers several ways to open an image file:

Using the Open Dialog-box

To invoke the Open dialog box, you have the following options:
- Select the [File > Open] command...
- Press [Ctrl + F12] keys simultaneously...
- Press the [Open] button located at the beginning of the application main toolbar...

Using Organizer

An image can be opened by double clicking its filename within the Organizer layout. Please see the [Organizer] chapter for more details.
Using the Recent Files List

You can quickly access the last opened images using the [File > Recent files] submenu. The number of the files listed in the submenu can be adjusted in the [Edit > General Options] window.

Using the Open Next/Previous/First/Last Commands

These commands enable you to continuously open the next/previous images from a particular directory or a database table. This is useful when editing multiple files placed in one directory. The commands are located in the [File > Open/Save Next] submenu. You can define sorting, filtering and other features in the [File > Open/Save Next > Open Next] settings dialog box.

Straight from Windows Explorer

During installation, NIS-Elements creates file associations to files that are considered a native format for storing images (JPEG2000, ND2). The JPEG2000 (JP2) and ND2 image files can be then opened in NIS-Elements just by double clicking their names in Windows Explorer.

5.3.2 Switching between Loaded Documents

The commands for managing the opened images are grouped in the [Window] menu. The presently opened files are listed in its bottom part. The currently displayed image is indicated by a check mark. To change the current image, select it from the list or use the [Next] or the [Previous] command (represented by [Ctrl + Tab] and [Ctrl + Shift + Tab] shortcuts).
5.3.3 Closing Documents

- The currently displayed image can be quickly closed by pressing the cross button, located in the top-right corner of the document window.
- The image can be also closed by invoking the [Window > Close] command or by pressing the [Ctrl+F4] shortcut.
- If you want to close all images, use the [Window > Close all] or the [Ctrl+Shift+F4] shortcut.
- If you try to close an image that has been changed, NIS-Elements will display a confirmation dialog box, offering to save the changes.

5.3.4 Image Formats

NIS-Elements supports the following number of standard file formats. In addition, NIS-Elements uses its own image file formats to fulfil specific application requirements.

**JPEG2000 Format (JP2)**

An advanced format with optional compression rates. Image calibration, text descriptions, and other meta-data can be saved together with the image in this format.

**ND2 Format (ND2)**

This is the special format for storing sequences of images acquired during ND experiments. It contains various information about the hardware settings and the experiment conditions and settings.

**Joint Photo Expert Group Format (JFF, JPG, JTF)**

Standard JPEG files (JPEG File Interchange Format, Progressive JPEG, JPEG Tagged Interchange Format) used in many image processing applications.

**Tagged Image File Format (TIFF)**

This format can save the same amount of meta-data as JPEG2000. TIFF files are larger than JPEG2000 files but are loaded faster. TIFF files have several ways to store image data, therefore there are many versions of TIFF. NIS-Elements supports the most common TIFF modalities.
CompuServe Graphic Interchange Format (GIF)
This is a file format commonly used on the Internet. It uses a lossless compression and stores images in 8-bit color scheme. GIF supports single-color transparency and animation. GIF does not support layers or alpha channels.

Portable Network Graphics Format (PNG)
This is a replacement for the GIF format. It is a full-featured (non-LZW) compressed format intended for a widespread use without any legal restraints. NIS-Elements does not support the interlaced version of this format.

Windows Bitmap (BMP)
This is the standard Windows file format. This format does not include additional image description information such as author, sample, subject or calibration.

LIM Format (LIM)
Developed for the needs of laboratory image analysis package. Nowadays, all its features (and more) are provided by the JPEG 2000 format.

ICS/IDS image sequence
ICS/IDS sequences are generated by some microscopes and consist of two files: the ICS file with information about the sequence; the IDS file containing the image data. The ICS file must be stored in the same directory together with the IDS file.
6.1 Histogram and Look Up Tables

6.1.1 Histogram Window

A histogram is a graphical display of tabulated frequencies. In NIS-Elements, it displays frequencies of pixels with a certain intensity value. The intensity values range from 0 (black) to 255 or 65535 (white) depending on the image bit depth. A separate graph is created for each color channel. Run the [View > Visualization Controls > Histogram] command:

![Histogram Window](image)

**Histogram Tools**

Source data of the histogram can be viewed by switching the tabs in the bottom-left corner of the control window.

**Export**

The source data or the histogram can be exported to an external file. Click the [Export] arrow button to select a destination from a pull-down menu.

*Please see the [Exporting Results] chapter for further details. The source data table will appear if you click the [Data] tab at the bottom of the control window.*
Graph appearance
The histogram can be zoomed in and out using the zoom buttons on sides of the window, or autoscale buttons can be used:

[Auto Scale Vertical] zooms in the graph of each channel separately. When this function is ON, the histogram is not proportional.

[Auto Scale Horizontal] zooms the graph so that the marginal zero frequencies, if there are some, are excluded from display.

The graph appearance can be modified via the following buttons:

[Show Grid] toggles display of the grid in the background.

[Options] displays the Histogram options dialog window where the following properties can be set:

- **Background/Axes Color** - the colors can be selected from a pull-down menu.
- **Pen Width** - width of the histogram line can be set to 1, 2, or 3 pixels.
- **Fill Graph Area** - The area below the histogram line can be filled with the channel color.
- **Graph Area Opacity** - select the opacity of the Graph Area fill in [%].
- **Vertical/Horizontal AutoScale, Show Grid** - these options equals the corresponding buttons of the histogram window.
- **Interpolation method** - select the way of drawing the graph line. The [Linear] (smooth) and [Quick] (precise) options are available.
- **AntiAlias** - smoothes the edges of the graph line.
- **Horizontal axis always visible** - if checked, the axis does not leave the graph area while zooming in the graph.

### 6.1.2 LUTs

A look-up table represents a useful tool for color modifications. It takes a value, maps it to a location in a table, and replaces the incoming value with the contents of the table entry. There are 3 modes of LUTs, depending on the image you are working with. Different controls will be available when applying LUTs to monochromatic, RGB, or multichannel image. When LUTs are activated the LUTs button in the top-left corner of the [document window] is highlighted red.
LUTs on RGB images

The main part of LUTs window is occupied by a histogram of the current image. There are 3 separate curves for each RGB component, and one gray filled curve for the whole image. You can adjust the histogram view by moving the slider in the left part of the window.

The black and white triangular sliders define thresholds. All the pixels with values smaller than the black slider indicates (left of the slider) will be displayed as pure black. All values to the right of the white slider (all pixels with higher values) will be displayed as white. The remaining color shades will be composed of the pixels with values between the two sliders with definable gamma parameter. Gamma is adjustable by moving the gray slider.

This button extends the sliders and displays the histogram as if LUTs was applied. The range of pixel values currently displayed becomes indicated in the top right corner.

Three color bars with sliders (displayed underneath the histogram) are representing RGB components. The slider movement affects the brightness of each component.

You can save the LUTs settings or load existing via the [Save/Load LUTs] button.
**Auto scale**

The [Auto Scale] button sets the white slider parameter automatically in order to enhance the image reasonably. If you select the [Use Black Level] option from the pull-down menu, the black slider will be affected too. If you select the [Find Best Gamma] option from the same menu, the Gamma slider position will be optimized as well.

It is possible to apply the auto scale procedure only once by pressing the [Auto Scale] button, or to run it permanently (on the live image) by selecting the [Keep Auto Scale] button. When you turn the Keep Auto Scale off, the settings remain as if the [Auto Scale] button was pressed once.

If you want to discard all LUTs settings, press the red cross button, located next to the [Auto Scale] button.

**Settings**

Press the arrow next to the [Auto Scale] button, a pull-down menu will appear. Invoke the [Settings] command.

![Auto Scale Settings](image)

[Quantile (0-10%)] - this value determines how many of all pixels of the picture are left outside the sliders when LUT is applied.

**AWB**

The AWB (Auto White Balance) mode adjusts the image to get the color neutral white. Similarly as the LUTs auto scale, it can be used once, or permanently on the live image by selecting the [Keep Auto White Balance] checkbox left of the [AWB] button. When you uncheck the box, the settings remain as if the [AWB] button was pressed once.

If you know which undertone your white has, you can select this color by the color picker that appears after pressing the [...] button on the right of the [AWB] button. And again, all changes are discarded using the red cross button.

The color overexposed button. When this button is activated, all pixels values of which reach maximum will be color-highlighted.
Press this button to apply the LUTs settings to the image data - the original image will be overwritten. Until you press this button, no changes are made to the image data.

**LUTs on Monochromatic Images**

All features mentioned above are also valid for monochromatic images. When adjusting a monochromatic image, you don't have the AWB function available and only one bar with sliders for the mono channel appears.

**Mapping Mode**

This pop-up menu is used for picking the mode of mapping. You can select from [Contrast] or [Window] modes.

- [Contrast] - all pixels with values higher than the white slider will be set to white.
- [Window] - all pixels with value higher than the white slider will be set to black.
Color Schemes

This button indicates the selected color table and displays a pull-down menu, where you can select the color scheme in which you want to display your image. Try a few of the schemes to see which one highlights most of the details you want to see.

![Color Scheme Buttons]

LUTs on Multichannel images

In case of multichannel image the histogram shows different color curves - each color for one color channel. To set LUTs for a single channel, this channel must be selected in the pull-down menu at the bottom of the LUTs window.

Auto Scale

A single channel can be adjusted automatically using this [Auto scale] button.

Look-up tables are useful for equalizing images. For example, if the image is very dark (which usually happens with quantitative cameras), you can restrict the view to display just the low pixel intensities. Hidden details then become more apparent.
6.2 Measurement

Measurement is an advanced and complex image analysis technique. It starts with calibration of the NIS-Elements system and finishes with a quantitative evaluation of the image.

6.2.1 Calibration

Calibration is of crucial importance to measurement. A calibration assigns real size to one pixel, so that correct and realistic measurements can be performed and the objects of different images could be compared to each other. A correct calibration has to be made before measurement begins. See the Configuring Attached Hardware chapter which explains how to calibrate the NIS-Elements system.

6.2.2 Rough Measurement

Quick and approximate measurements can be performed utilizing graticules. They behave like adjustable floating rulers. User can simply align a graticule with the measured object and read the distance value (e.g. the diameter). To activate the graticule, press the [Graticules] button placed in the top-right corner of the document window.

Select Graticule Type

The type of the graticule ruler is indicated by a picture on the [Graticules] button. To change the graticule type, click on the graticules button with the right mouse button and select the appropriate item from the context menu:

- Rectangular Grid
- Circle
- Simple Circle
- Cross
- Industrial Cross
- Simple Cross
- Vertical Ruler
- Horizontal Ruler
Define Graticule Properties

Right click the [Graticules] button and select the [Graticules properties] command from the pull-down menu. A dialog window appears where display parameters of all graticules (shape, color, line width, density of lines) can be adjusted.

Density

The density value - the closest distance between two line intersections of the graticule - can be set, or you can let NIS-Elements adjust it automatically according to the current zoom factor. The units selection depends on the image calibration (calibrated/uncalibrated).

Measure the Image

The graticule measurement offers the following options:

- The graticule can be moved by mouse arbitrary.
- The graticule position can be reset by using the [Move Graticules to Center] command from the context menu.
- A new image containing graticules can be created by the [Edit > Create Full View Snapshot] command.

6.2.3 Manual Measurement
Length, area, angles, taxonomy, counts, circle radius, and ellipse semiaxes can be measured manually over an image. The results are being recorded to a simple statistics table, which can be exported to a file or clipboard. Also, the data can be presented as a graph.

- Run the [View > Analysis Controls > Annotations and Measurements] command. The manual measurement control window appears.
- Select a tool corresponding to the feature you are going to measure. There are several tools for measuring each feature.
- Measure the objects in the image using mouse.
- Select where to export results in the [Export] pull-down menu.
- Export the results using the [Export] button.

**Example:**

Measurement of a crystal: Select the *Horizontal parallel lines* tool. Place the first line on the top edge of the crystal by clicking into the image. The position of the line can be adjusted while you hold the left mouse button down. After you release it, the line is positioned. Repeat this to place the second line on the bottom edge of the crystal. When finished, an arrow is drawn between the lines, and the result of the measurement is attached. A record with the measurement type and measured value is added to the results table.

*Please see more about manual measurement tools in the Command Reference of the help.*
6.3 User Macros

A macro - an executable sequence of commands - can make the work very effective. NIS-Elements provides a C-like programming language utilizing its internal set of commands. The sequence of commands can be created either by recording the performed actions, by writing the commands inside the macro editor, or by modifying the command history (the history is recorded automatically during the work). The created macro can be saved to an external (*.mac) file for later use.

6.3.1 Recording a Macro

The fastest way to create a macro is to record it.

- Start the NIS-Elements macro recorder by selecting the [Macro > Record] command.
- Perform the series of actions you would like to record.
- Finish the macro creation by the [Macro > Stop Recorder] command.
- It is recommended to check the macro in the macro editor before saving. Run the [Macro > Edit] command to display it.
- Save the macro to a file via the [Macro > Save As] command.

6.3.2 Writing/Editing a Macro

A macro can be written by hand in the built-in macro editor. Run the [Macro > Edit] command to display it.

The macro editor provides:

- Direct output to a printer.
- Undo/Redo functionality.
- Command insertion from the list of available commands.
- Interactive command names list. Press [Ctrl+Space] to display a simplified list of all commands while typing the macro.
- Syntax hints appear as you type a command name. Parameter types and names appear.
Chapter 6  Image Analysis

- Bookmarks can be placed to the code so you can easily roll to the important parts of the macro.
- Breakpoints can be placed to the code. A breakpoint forces the macro to stop the execution at a certain point so you can check variables state, and inspect the macro "per partes".
- Syntax highlighting.
- Help on commands with detailed description.

6.3.3 Creating a Macro from History

You can create a macro using the list of recently performed commands. Run the [Macro > History] command to display the list and push the [Create Macro] button. The "Create Macro" wizard appears. You can also call this wizard from within the macro editor by pushing the [Insert Commands from History] button.

1. Creating Macro - Select Commands (Step 1 of 4)

Pick single commands holding the [Ctrl] key, or select a range holding the [Shift] key down. The selected commands will be used in the macro.
- [History] - number of commands performed in the current NIS-Elements session.
- [Currently] - number of currently selected commands.

2. Creating Macro - Remove Redundant Commands (Step 2 of 4)

[Remove redundant commands] - the sequence of commands that make no image changes is automatically removed. Usually, it concerns commands that toggles the image between two states and were used several times in a row. It can be for example the ShowAnnotations(), ShowProbe(), or EnableLUTs()
command. No functionality is lost when only the last command is kept.

3. Creating Macro - Edit Single Command (Step 3 of 4)

- Reverses changes that you made within this dialog window such as cutting, copying, pasting or inserting commands.
- Removes the selected command(s) and copies it to clipboard.
- Copies the selected command(s) to clipboard.
- Inserts the command(s) from clipboard before the currently selected command.
- Opens the list of commands and enables you to edit the parameters of the selected command (or even change the command).
- Inserts a command from the list of all commands. Select the command you want to paste and press the [OK] button.
- Inserts a special command. The dialog window that appears includes the most frequently performed actions, such as Run Macro from File, Pause Macro, etc. Select the action you would like to insert and press the [Insert] button.
- Displays the help page of the selected command.

4. Creating Macro - Saving As Macro (Step 4 of 4)

The last window of the wizard is a standard [Save As] dialog window. Select the destination folder and the macro name and confirm it by the [OK] button. Or, the macro can be saved as [Untitled] which is NIS-Elements default macro (it is always loaded in the list of macros). Press the [Untitled] button (the [File Name] path is filled automatically) and the [OK] button.
6.3.4 Saving a Macro

When you create a macro by recording, you can save it using the [Save or the Save As item in the Macro menu. To save a macro during editing it, press the Save button in the macro editor.

6.3.5 Running a Macro

NIS-Elements provides several ways to run a macro.

- You can run the current macro loaded to NIS-Elements by choosing the [Macro > Run] command or by pressing [F4].
- You can run a macro that is opened by the [Macro > Open] command by pressing [F4].
- You can run a macro directly by pressing a special [hotkey] combination (Ctrl+Alt+1,2,3 ... 9) that you have assigned to it in the [Macro > Options] dialog window.
- You can run a macro at the beginning of the NIS-Elements session, by assigning the [StartUp] flag to the macro in the [Macro > Options] dialog window.
- You can run a macro directly by using the [Macro > Run From] command.
- You can run a macro by clicking a tool bar button that you have assigned to it by the [View > Customize Toolbar > Setup] command.

6.3.6 Breaking a Macro

The macro execution can be stopped by pressing the [Ctrl+Break] key shortcut.
6.4 Creating Reports

Report Generator enables a user to create customized reports containing images, measured data, user texts, graphics, or database entries. PDF files can be created directly from NIS-Elements. When you invoke the [File > Report > New Blank Report] command, an empty Report Generator appears. It provides the following tools:

- Draw line...
- Draw rectangle...
- Draw ellipse...
- Draw Arrow...
- Insert text field...
- Insert image from file...
- Insert Table
- Insert graph

Aligns the selected objects to the position indicated by the line (left)

Aligns the selected objects to center

Distributes the objects regularly in specified direction

Determines whether to apply the align commands relatively to the whole page or to selected objects

Context Menu

Once you insert an object, its appearance, behavior, and position can be changed via the context menu which appears on right-click:

- The [Align or Distribute] command enables moving objects within the page or aligns them to another object.
- The [Resize object] command enables to resize two objects to the same size.
- The [Bring to front] command changes the order of overlapping objects and brings the current object to front.
• The [Send to back] command moves the object to the bottom layer.
• The [Lock] command locks the object disabling any further changes to it until it is unlocked.
• The [Properties] command opens a dialog window where object properties such as color, background color, border size and color, object size, font, aspect ratio, alignment, and shape can be adjusted.

6.4.1 Working with Report Objects

When you double-click any of the objects of a report, a dialog window appears where the properties can be adjusted. Some properties are common for all types of objects, and some are special.

Common Properties

• The precise position can be determined by defining the XY coordinates of the top-left corner of the object.
• Line and fill colors can be selected in a pull-down menu.
• Line widths can be adjusted within the range of 0.75 to 6.0 pts.
• Precise width and height of the objects can be adjusted.
• Rotation of some objects can be adjusted.

Special Object Properties

Ellipse
• Minor and major axes lengths can be modified.

Arrow
• The arrow tip shape and size can be modified.

Text Box
• Format of the text can be adjusted like in a standard text editor.
• The current date and time can be inserted from a pulldown menu.
Image
- A new picture can be loaded to the image frame via the [Load Picture] button.
- The current image scale is displayed in the properties dialog window. It shows the current scale/original image dimensions ratio (the image must be calibrated to use this feature, e.g. scale 1:2 means, that the image will be printed in half of its original size).
- A scale bar can be displayed below the image. The position and width of the scale bar can be defined.

Table
- Inner and outer borders can be hidden/displayed arbitrary.
- Number of row/columns can be modified.

Graph
- The range of displayed values can be limited by defining the min/max values.
- Histogram labels can be edited.

Aligning Objects

You can align two objects to the same horizontal or vertical level.
- Select more objects (e.g. by holding down the CTRL key and clicking with the left mouse button).
- Right-click one of the selected objects and select the [Align or Distribute > Align ...] command from the context menu.
- The objects will be aligned as indicated on the command icons.
- If the [Relative to Page] option is turned ON, the objects will be aligned to the edges/center of the page.

Objects of similar size can be distributed uniformly in the horizontal/vertical direction.
- Select three or more objects.
- Right click one of the objects and select the [Align or Distribute > Distribute...] command from the context menu.
- Distances between the objects will be adjusted to equal.
- If the [Relative to Page] option is turned ON, the marginal objects will be moved to the edges of the page.

Sizes of objects can be unified too.
- Select two or more objects.
• Right-click the "master" object to the size of which you want to resize the other objects.
• Select one of the [Resize Objects] submenu commands.

**Dynamic Data**

Results of interactive measurement, graphs, or the current image can be inserted to reports.
• Insert an object which can contain dynamic data (text, picture, table, or graph).
• Right-click the object and select [Insert Dynamic Data/Insert Dynamic Picture] from the context menu.
• A dialog window appears.
• Select one of the available sources, and click [Next].
• Finish the source definition and click [OK]. The data appear on the report page.

**List of available dynamic data sources:**

• **Data inserted by user** *(available for: image, text, table)* - the system will ask you to type a text or browse for an image to insert during the report creation. When creating a dynamic object of this type, a query text which will be used to prompt you for the data can be defined.

• **System data** *(available for: text, table)* - enables you to insert some general data such as date, the name of the user account currently logged in, the page number, or the page count.

• **Macro** *(available for: text, table)* - enables you to insert expressions, values, or results of the macro which is running simultaneously.

• **Measurement** *(available for: text, table, graph)* - enables you to insert results of interactive measurement.

• **Database** *(available for: image, text, table)* - this data source is displayed only when creating a database report template (see below). It enables you to insert a link to any of the database records.

_The real purpose of the dynamic data turns up when creating reports using report templates:_

### 6.4.2 Working with Report Templates

A report template is a layout of the future report(s) which is ready to be filled with data. The data can be inserted by the user "on demand" or automatically (dynamic data).
To Create a Report Template

- Edit the report template in the same way as a common report.
- Insert the dynamic data where it is appropriate - measurement results to text boxes/tables, the current image to the image field, etc.
- Save the report template (*.rtt) via the [File > Save] command.

To Insert Dynamic Data to Report Templates

- Insert an object which can contain dynamic data (text, picture, table, or graph) to the template.
- Right-click the object and select [Data Source] from the context menu.
- A dialog window appears.
- Click the [Define] button. Another dialog window appears.
- Select one of the available sources, and click [Next].
- Finish the source definition and click [OK]. The data appear in the template.

To Create a Report from the Template

There are two ways of creating the report.

- If a template is opened inside the Report Generator, run the [Report Generator > File > Create Report] command. Otherwise, use the [NIS-Elements > File > Report > New Report from Template] command to open a template from harddisk.
- A report opens and the dynamic data is inserted automatically.
- Save the report, print it, or export the page(s) to PDF using the commands from the [File] menu.

6.4.3 Creating Reports from Database

Pictures of a database together with the associated table data, or common images with the associated [Image Info] can be exported straight to a report.

- Switch NIS-Elements to [Organizer] by the [View > Organizer Layout] command.
- Select one or more images. These images will be exported to the report.
- Click the [Report] button on the main toolbar. The following dialog window appears:
• In the [Columns] section, you can select fields, which will be included in the report. If you are exporting the images from database, you can select database fields. If you are exporting images from a directory, this enables you to select the image text description fields (applies only to images with text info: JPEG2000, LIM and TIFF).

• The [Template] portion of the dialog specifies the report template. If you select the [Standard] template, images will be organized in rows and columns. It is possible to set the number of columns and rows.

• If you select the [Custom] report template, then a user report template (*.rtt) can be opened from the disc and used for the report creation. If there is an existing report template, click on the [Browse] button, otherwise click on the [Create new] button.

**After You Pressed the [Create New] Button**

• A wizard appears. Select number of columns and rows of the new report template. Click [Next].

• Select the paper size, page orientation, and define margins. Click [OK].

• An untitled report template opens containing a grid spaced according to the [columns/rows] settings.

• Edit the top-left cell of the grid. You can change the text/image boxes position, size, and mapping. During report creation, the other cells of the grid will be filled automatically according to the settings of the first one.

• A custom header or automatic page numbering can be added to the report.
6.5 Exporting Results

Some image analysis data and measurement tasks results can be transferred out of NIS-Elements so they could be used further. This regards for example the intensity profile, histogram, measurements control windows. There is a standard [Export] pull-down menu in some of the control windows which enables the export:

The set of commands of the menu differs according to the control window type. Click the [Export] button to display the pull-down menu. When you select the subject of export and the destination, the pull down menu hides and the icon corresponding to what you selected appears on the [Export] button. The export action is performed after the button is pressed once more.

6.5.1 Export Destinations

It is possible to export tabular data or a graph:

**To MS Excel**

Tabular data can be exported to MS Excel. A new XLS sheet opens and the table is copied to it automatically. Sometimes, there is also the [Export (All) To Excel] option, which copies the tabular data and the graph image into the sheet.
### To a File

Data tables can be exported to an external *.txt file, graph images to a *.bmp file. Select the command from the pull-down menu and define the target file name in a standard Save As dialog window, which opens. Confirm the export by the [Save] button.

### To Clipboard

Data tables and graph images can be exported (copied) to Windows clipboard. Then the data or the image can be inserted into any appropriate application (text editor, spreadsheet processor, graphics editor) typically by the [Paste] command.

### To Report

Tabular data and graph images can be exported to NIS-Elements report. If a report is already opened for editing, the data/graph will be appended to it. Otherwise, a new report will be created and the exported data inserted to it.

### To Web Browser, To Clipboard as HTML

Some tabular data can be exported as a HTML table. It can be displayed in a default internet browser (the [To Web Browser] option), or the HTML code can be copied to Windows clipboard, ready to be inserted to any HTML editor.
7.1 Tips & Key Shortcuts

7.1.1 Interactive Channel Selection

Two or more channels can be selected to be viewed:

- Click the appropriate channel tabs while holding the [Ctrl] key down.
- If some processing is performed, it is applied to the selected channels only.

7.1.2 Shifting channels

Selected channels can be shifted using the [CTRL + SHIFT + cursor keys]. All channels are visible during the operation so you can see the complete image.

7.1.3 Live Image, Frozen Image

- [+] turns the [Live - Fast] camera mode ON.
- [-] freezes the Live image.
- [Ctrl] + [+] turns the [Quality - Capture] camera mode ON.
- [Ctrl] + [-] performs image acquisition in the Quality - Capture mode.

ROI on a live image

You can specify the ROI on a live image by clicking the [Define ROI] button. In a dialog window that appears set the dimensions of a ROI rectangle.

7.1.4 LUTs

A context menu can be displayed when right clicking the LUTs graph area. The following options can be selected:

- [Draw trend style] - When ON, the LUTs curves will be smoothed to display the data trends rather then represent the actual image data values.
- [Copy LUTs, Paste LUTs] - The current LUTs settings may be copied and inserted to another image.
The position of each triangular slider at the bottom of the LUTs window can be reset by double clicking it. The pixels that reach the maximum value can be highlighted using the LUTs [Color Overexposed] button.

### 7.1.5 Modifying Application Appearance

- All buttons on main tool bars may be enlarged. Go for [View > Layout > Layout Manager], select [Toolbars] in the layout tree, and check the [Large Buttons] option. It affects all layouts.
- The channel tabs at the bottom of image window may be hidden to save some space of the screen. Go for [Edit > General Options > Appearance] and unselect the [Show Channel Tabs] option.
- When an image is displayed in great magnification, scroll bars automatically appear by the sides of the document window. You can hide them by selecting the [Hide Scroll Bars] command from a context menu (right click inside the image).

### 7.1.6 Key Shortcuts

- **[Z]** - It switches to the [Magnifier Glass] tool. When a detail is being observed with Magnifier Glass and you press the [Z] key again, local contrast enhancement is performed inside the magnified area. This feature may help to increase the contrast of dark parts of images that are no more enhanced by the global LUTs settings.
- When using the Magnifier Glass tool, pressing the [Ctrl] key switches to pointing tool functionality temporarily (so that the image can be dragged by mouse).
- If the [Shift] key is pressed while applying the Magnifier Glass, you can move the magnified part of the image aside.
- When applying the Magnifier Glass to a Z-ND document, pressing the [Ctrl] key changes the mouse wheel functionality. The mouse wheel zooms the image instead of browsing through the Z-sequence.
- **[X]** - It performs the Create View Snapshot command. The snapshot includes even the magnifier glass tool when the X shortcut is pressed while observing a detail.
- **[']** - Zooms the current image to Fit to Screen mode.
- **[1]** - Zooms the current image to 1:1 mode.
- **[2]** - Zooms the current image to Best Fit mode.
- **[Up]** - Increases zoom of the image.
- **[Down]** - Decreases zoom of the image.
7.1.7 Context Menus

Number of context menus can be displayed by clicking the right mouse button on various items throughout the application:

**Main Status Bar**

- **Layout Tabs** - [Save Current Layout As] and [Layout Manager] commands are available.
- **Selected camera area** - the [Select Camera] command is available.
- **Command History area** - the [Command History] or [Execute Command] dialog windows may be invoked.
- **Current Objective area** - [New Optical Configuration] and [Optical Configurations] commands are available.
- **Profiler area** - [View Profile Results], [Reset Profiling], and [Enable Profiling] commands are available.

**Document Status Bar**

- **Channel Tab area** - [Copy Channel], [Paste Channel], [Remove Channel], [View Channel In Color], and [Properties] commands are available.
- **Document Calibration area** - [(Re)calibrate Document] and [Calibrate Using Objective] commands are available when the current image is Uncalibrated.
[Precision] of the calibration display, [Units] to work with can be set, and the [Recalibrate Document] and the [Set Document] as Uncalibrated commands are available when the current image is calibrated.

- **Mouse Position area** - Color space to show the pixel values in can be selected (if an RGB image is opened).

- **Image Info area** - [Show Dimensions in Units] and [Show Dimensions in Pixel] options are available (when the current document is calibrated).
7.1.8 Mouse Wheel

Zooming

The mouse wheel serves for zooming images in/out by default. Its behavior differs according to the type of the currently opened document:

- **ND files containing Z** - browses through the Z stack of images.
- **Other document types** - zooms the image in/out.

\[\text{Ctrl} + \text{mouse wheel}\] - zooms in/out every image including the Z-ND files.

Auto Detection Tools

Some auto detection tools use the mouse wheel for adjusting the detection parameters. This regards the [Auto Detect] tool of the [View > Analysis Controls > Binary toolbar], and of the [View > Controls > Annotations and Measurements] control windows.

7.1.9 Vector Objects

Vector objects (report objects, annotations, interactive measurement objects) can be copied by "drag and drop" while holding the [Shift] key down.

- Select the object(s) (text, shape, interactive measurement).
- Press [Shift] and drag the object somewhere.
- A copy of the object is placed where you release the mouse button.

Default Color Settings

The default colors of vector objects can be set in the following way (each annotation tool keeps its own color, manual measurement objects share the color settings):

- Draw a vector object.
- Right click the object and select [Properties] from the pull-down menu. A dialog window appears.
- Adjust the color (and other) settings and confirm them with [OK].
- The settings will be used when drawing subsequent objects of the same type.
8 Additional Modules

8.1 Database Module

NIS-Elements offers a database tool to efficiently manage images along with additional information. After you install the Database module, the [Database] menu appears in the main toolbar.

A database is an organized body of related information. It consists of one or more database tables filled with data. Before you can start filling the tables, you need to create a new empty database. This can be done by selecting the [Create database] command from the Database menu.

Note: NIS-Elements supports also SQL databases, MS SQL and Oracle.

8.1.1 Creating Database

Select the Microsoft database engine in the left list and the [Blank] template from the list of templates. Click on the [Next] button.

Specify where the database file should be stored on a disk - define the [Database File Path] ("C:\Databases\minerals.mdb" for example) and the database file name. You, as the database creator, are automatically considered as an administrator (the user name and password are "sa" by default). The administrator is a user with all possible rights to the database. Next, define a descriptive name of a connection point, e.g. [Test] for the testing database. Click [Finish] and an empty database is created and connected through a connection point (see below).
Creating Tables

A database can contain one or more tables to store your data to. Select the [Create table] command from the Database menu.

Select the session from the left list. In our case, there should be only one: “[Test(sa)]”. It means: the user “sa” is connected to the database through the “Test” connection point. It is possible to have one user connected to more databases or more users connected to the same database on one system. On the right side, choose the [Blank] template and click the [Next] button.

Enter the [Name] of your new Table (e.g. Minerals). The Description editbox isn’t necessary to fill, but it might prove helpful to put down a short comment.

Define the table fields. First, click to the [Name] field and fill it in (e.g. Author). Press [Enter] and define the data type of this field. This is done by selecting one option from the combo box, which opens after clicking into the [Type] field. Select the [Text] type, because names are usually short enough to fit in this data type. The [Is title] field determines, which database entry is used as a description of images while viewing the table using the thumbnails view of Organizer. Define all fields you want to include in the database table and click [Finish]. The new table is created.
Special Field Types

Let’s assume that pictures come from a closed group of people. In this case it is useful to set the field type of the “Author” field to [Enumeration]. The Enumeration value edit box on the right becomes active and you can enter all names of possible authors. When adding a new image to the database later, you can just select the author’s name from the combo box instead of having to type it.

Another special field type enables to insert arbitrary external links into database tables. Select the [External Link] option as the field type. Later, you can insert a command, link to a website etc. to these fields.

File Field Mapping

It may be very handy to insert some image properties to the database. Therefore the [File field mapping] can be used to map file properties (such as filename, file date, calibration, author etc.) included in the image file to the table fields. Select the information type from the combo box. If the <default value> is selected, fill in the [Default] value text box and that text will be used for every database entry added to the table.

Managing Tables

After you have created one or more tables, you can manage them easily using the [Remove Table] and [Modify Table] commands from the Database menu. Each command opens a dialog window.

The Modify Table command asks you to select a table to modify and opens the table properties window.

The Remove Table command removes a table from a database. However, the database images may optionally not be deleted. A directory to store images of each table is created during the table creation. The directory has a name that matches the name of the table and is placed in the directory where the database file is stored. Copies of the source files from your disk are created in there for database purposes.
If you check the [Delete also images linked to the table] check box during the table removal, all these copies are deleted from your disk. Otherwise, the copies remain untouched.

*Are you sure you want to delete the database table 'Minerals'?*

- [x] Delete also images linked to the table.

---

### Adding Images to Database

You have successfully created a database with at least one table. Use it to store pictures with descriptive information. Every time you choose the [File > Save to Database] command, you will be prompt to pick a table to write in. The [Save] button invokes a window to fill the database entry information and saves the current image into that table. View the database records in the [Organizer] view (the [F10] hotkey).

---

#### 8.1.2 Connecting to a Database

**Connection Points**

Connection points are intended to ease work with databases. A connection point has similar functionality to file shortcuts or links. It can be named arbitrarily and you can access the database through it. It is allowed to create and use one connection point per database here.

Let’s suppose you have a database created. Launch the [Create Connection Point] command. Write the connection point name and select the path to the database file in the wizard that opens (once you have created the connection point, you can manage user accounts and permissions of the related database by selecting the [User Accounts and Permissions] command from the Database menu). You can also create more or
delete some connection points in the connection points manager (Database menu > Connection Points submenu > Manage Connection Points command).

**Connecting to Database**

Use the [Connect] command to connect to a database. Select the connection point (representing the database) from the combo box. In case this combo box is empty, press the icon on the right side to create a new connection point.

**Authentication**

To access the database, a user authentication is needed. If the [Windows authentication] option is chosen, the username and password of your windows account are used when logging in. [The Native database authentication] requires entering the username and password which is valid for the database you want to connect to. Click [OK] to connect.

**Active Connections**

You can view the list of active connections in the [Organizer] view (F10 key shortcut). The [Disconnect] menu command displays the dialog box where you can select the connection point to be disconnected. Disconnecting the point closes the way to save images to the corresponding database for the user. Still, you can access the other databases through other connection points.

Every user who possess rights to the database administrator account (with the username “sa” by default) can manage other user accounts using the [User accounts and permissions] menu command.
User Accounts and Permissions

The [Create user] button displays a dialog box (see below). The [Delete user] button displays a confirmation dialog box - when [OK] is pressed, the user is deleted.

The Change password button enables to set a new password for the selected user. The dialog box with two editboxes (the new [Password] and its [Confirmation]) appears. The [Change properties] button opens an advanced dialog box where you can set various user rights.

Create New User Account

The user creation allows you to choose between the [Regular user] (this option enables to create an arbitrarily named user) and the [User from Windows account] (it is possible to choose from users, who have a windows account on the current computer).

Write a new user name to the [User name] box or select existing user from the list of windows accounts. You can add any comments to the [Description] box. Enter a [Password] twice ([Confirm Password]) and [Create] the new user.

Multiple connections to databases using different user accounts are permitted. If some intended operations are unavailable, check whether you are logged under the correct user account with adequate rights.
User Permissions

Having sufficient privileges, you may change the other user’s accounts properties by pressing the [Change properties] button in the [User Accounts and Permissions] window. The dialog box, where it is possible to set user rights for various actions performed on a database, opens. To set or ban the rights, click into the check boxes. There are three main sections in the dialog window: the [User rights], [Tables] and [Fields].

The User rights section

This section is used to define, what actions are allowed for the selected user in relation to other users and all databases. Decide, whether the user can delete, modify, create user accounts or delete and create tables. The “sa” (database administrator) user’s properties cannot be modified nor that account can be deleted by other users.

The Tables section

Displays a list of existing tables. It is possible to set rights to view, create and delete whole records, as well as rights to create and delete single fields of a table. When the [Delegate rights] check box is checked, the user is allowed to modify permissions of other users for that table.
**The Fields section**

More detailed settings for each table are listed here, if the table was selected in the [Tables] section. You can only see the fields that your privileges allows you to view. You can set, if the user will be able to view or modify every single field.

![Fields section image]

<table>
<thead>
<tr>
<th>Field</th>
<th>View</th>
<th>Modify value</th>
<th>Modify type</th>
</tr>
</thead>
<tbody>
<tr>
<td>Sample</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
</tr>
<tr>
<td>Type</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
</tr>
</tbody>
</table>

**Changing Password**

You can change a password to a database via the [Change password] command from the Database menu. Enter your old password, and a new one twice to prevent a typewriting mistake. The [Change] button finishes the operation. A user with a privilege to “[Modify user]” can change the other user’s passwords via the User Rights and Permissions menu command.

![Change Password dialog]

**Session:** Minerals (sa)

**Old password:**

**New password:**

**Confirm new password:**

[Change] [Cancel]
8.1.3 Database Backup

A possibility to backup the database is essential and strongly recommended for any serious work. The [Database Backup Scheduler] enables the system to backup the database automatically once in a precisely specified time interval, so you do not have to be afraid to lose any data. The Database Scheduler uses the standard Windows “[Scheduled Tasks]” tool (Start > Control Panel > Scheduled Tasks). Once you schedule a backup, there is only one condition to perform it successfully: The computer must be [ON] at the scheduled time.

Backup Settings

To set a new periodic backup, click the [New Task] button. In the dialog window that appears, specify the task name and click [OK]. If you already have some task that suits your needs, it is possible to copy its properties by checking the [Based on] check box and choosing its name from the list.
Since the task is based on the Windows component, it is necessary to run it under a Windows user account. Either a local or a domain account is allowable (the domain name “[LAB]” is used in our example). After filling in the password, decide how often the backup shall be performed. Daily, weekly, and monthly intervals with a precision of seconds are available.

Furthermore, the location of three following files on a disk is needed. Use the [Browse] buttons on the right side of the textboxes to specify the paths to the [Source database] file (the file to be backed up), the [Destination (backup) database] (a directory to which the backup file will be written) and the [Backup log] file where the information about the backup process is stored. The specification of all three destinations is mandatory. Without it, the backup cannot start.

**Detailed Backup Settings**

In the Source database settings, there are the Database account and Password text boxes. They are not editable and are for information only.

**Backup History**

When performing a backup periodically, the already existing (the latest) backup file’s content is moved to a new history file and a suffix with the iteration number is attached to its name. The new backup file is created. This way, an unlimited number of the history backup files is being created on a disk. When you limit the number of history files (e.g. to prevent the disk capacity overflow), each time the scheduler replaces the latest file with the new one, it also renames all the other backup files accordingly. As a result, the file names and their number on a disk remain the same (although their content changes).
**Backup Logging**

The amount of information to be written to the backup log file is determined by the [Level] choice. The [Details] option records changes of all files of a database compared to the previous backup. If you choose to record the [Summary] only, possible critical errors and backup process results are included in the log file.
8.2 The Extended Depth of Focus Module

The EDF module allows you to combine existing Z-stack images into one focused image picking the focused regions from each frame and merging them together. The “Align” algorithm ensures correct fitting of pixels even for images acquired via macro optics, where objects are slightly shifted or scaled during the z-stack acquisition.

When you start NIS-Elements with the EDF module installed, the following items appear in the [Applications] menu:

- Open File Sequence
- Align Sequence
- Create Focused Image
- Edit Area in Focused Image
- Real Time EDF
- Real Time EDF Manually
- Options

Open (or acquire) an ND2 document that includes the Z dimension. If you use the [Open File Sequence] command to get the Z stack of images, a new ND document is created automatically.

Align Sequence

Small shifts of the images can occur as a result of hardware inaccuracies during the Z series acquisition. To get reliable results out of the EDF module, the sequence that is to be processed should be aligned first. Use the Align Sequence command to automatically correct possible shifts.
Select the method

Once the sequence is aligned, invoke the [Options] command to select the preferred method of creating the focused image. The following dialog window appears:

**Smooth (default)**

The focused image is created step by step. In each step, this method computes the focus criterion for each pixel and compares them. It has two parameters which you can change according to the needs of a sequence.

- **Level** - Affects the smoothness of the focus criteria in the image. Higher settings mean that the focused areas in the image will affect larger neighborhood. The default setting is Standard.
- **Blending** - When the focus criteria in the source frames are similar, the pixels from those frames can be combined and the transitions between the focused regions in the result image will be smooth. The higher blending you select, the more differing pixels will be combined.

**Local**

This method computes the focus criteria in another way than the Smooth method. It finds the focused regions of the source frames and copies them to the result image. An additional processing of the regions removes the badly detected ones. However, borders (transitions) between some regions might be clearly visible at the end.

**Fluorescence**

Similar to the Local method, but it uses different focus criteria optimized for fluorescence images.

**Maximum intensity**

The focus criterion is the intensity of each pixel. The pixels with the highest intensities of all frames are copied to the result image.
Creation of the Focused Image

When the method is selected and the sequence is aligned, the only thing to do is to run the [Create Focused Image] command. The focused image will be created and appended to the ND2 document (when the ND2 file is saved to disk the focused image is included.)

8.2.1 Viewing of the Result

After the focused image is created, all buttons of the EDF tool bar (located inside the document window) become enabled. There are three ways to observe the resulting focused image, as:

- A common Color/Gray image.
- An anaglyph - to be viewed using special 3D glasses.
- A 3D model, using so called Surface View.

This button displays the focused result image.

Creating Anaglyph

Using this button, you can create three-dimensional stereo images (anaglyphs). These images shall be observed with special glasses having red and green or blue filters. This provides a 3D impression. Click the nearby arrow button and select the [Anaglyph options] command.

The following dialog box appears.
The first frame is the
Defines the direction of the z-axis sequence. Can be *highest* or *lowest*.

The result will
Defines the stereovision impression, which you will experience using special red-green glasses. Can *descend into the screen* or *rise from the screen*.

Enhance sequence height
Enhances the depth feeling.

Gray-scale anaglyph
Creates a gray-scale anaglyph. If not checked, the anaglyph is color.

Left filter color
You can select the color of your glasses. This option is crucial to get the right 3D impression.

Exploring the surface view
This button runs the built in surface viewer.
The 3D viewer displays the surface of a captured object three-dimensionally.
For proper view, it is necessary to set whether the first frame in the sequence is the lowest or the highest one (set this by the rightmost icon).

You can also adjust the sequence height for more credible look via the [Z-zoom] combo box.

Navigate the view by sliders on sides or by mouse. A mouse wheel serves for zooming.

[Show Crop Plane] - enables the mode when to crop image (view) is possible by Ctrl key and mouse.

[Toggle Scene Lighting] - switches on/off the lighting of surface view.

The 3D model can be exported to VRML (Virtual reality modeling language) format for distributing and viewing outside of NIS-Elements software. This format is platform independent and is used mainly on the internet.

To export the image to VRML, press the [Export to VRML] button. Two files will be saved. One that contains the 3D information (WRL) and the other that is a 2D texture (JPG). Mind, that both files must be distributed (e.g. placed on the web) together!

To view files in VRML format some VRML viewer is needed. The viewer is a plugin to your web browser. There are several viewers available for free:

- **Cosmo Player** - [http://ovrt.nist.gov/cosmo](http://ovrt.nist.gov/cosmo)
- **Cortona** - [http://www.parallelgraphics.com/](http://www.parallelgraphics.com/)
Cropping Plane
To crop the image select the [Show Crop Plane] command. Ctrl key displays the cropping plane and the axis of rotation. Hold the Ctrl key down and drag the cropping plane or the axis of rotation with left mouse button to new position. Press Ctrl key together with right mouse button to rotate the cropping plane.

8.2.2 Edit Area in Focused Image

This advanced option enables you to draw an area inside the image and select the Z slice to be used in the resulting focused image.

• Display the focused image.
• Select the [Edit Area in Focused Image] command.* The cursor changes.
• Draw an area inside the focused image which should be affected. Finish drawing by right-click.
• Use the mousewheel or arrow keys to browse Z slices within the area.
• Finish the procedure by right-click or [Enter].

* - when you have the area defined, the selection can be inverted by pressing [G].
8.2.3 Real Time EDF

The [Real Time EDF] command is integrating the whole functionality of EDF. It captures a Z-sequence, aligns the images (optionally), and creates the focused image. When the [Real Time EDF] command is invoked, the [Capture Z Series] dialog window appears with the [Align images] check box added. There you can set whether to align the images or not.

If the [Real Time EDF Manually] command is used, not requiring to posses a motorized Z-drive, the [Acquire > Capture Z Series > Capture Manually] dialog window appears with the [Align images] check box added. It behaves the same as the [Real Time EDF] procedure except for the manual way of capturing the Z sequence.

*Please see more details about the dialog window in the [Z Series Capturing] chapter.*
8.3 Metallography

8.3.1 Cast Iron Analysis Module

After the module installation, a new item called [Metallography] appears in the [Applications] menu. Select the [Cast Iron] command to run the application. The appearance (toolbars and the main menu) of the application will be modified.

Main Features of the Cast Iron Analysis Module:

- Graphite classification according to ASTM/JIS standards (ASTM A247-06, JIS G5502).
- Ferrite/pearlite ratio measurement.
- Customization of the predefined measurement procedures.
- Easy data export.

Quick Guide

- Open/acquire the image to analyze.
- Set the structure type and the detection procedure parameters within the [Detection] tab.
- Set the measurement procedure parameters within the [Measurement] tab.
- Run the [Measure > Measure] command.
- View the measured data within the [Data] tab and export it to one of the available outputs via the [Export] button.

_The analysis can be performed even on two or more images sequentially. After defining all the parameters, run the [Measure > Measure Sequence] command._
Detection Options

Once the Cast Iron application is run, the [Detection] tab appears in the right-side docking pane.

- Select one of the structure types (presets). This selection influences the set of available detection tools.
- Select the detection type. One of the easy modes can be selected, or an arbitrary sequence of operations can be created.
- Enable/disable the pre/post-processing operations, and adjust the [Threshold] settings.
- Use the [Save] button to store changes of the current preset, or use the [Save As] button to add the current settings as a new preset, then press the [Save] button to store the setting.
Select Structure Type

- Two different structure types are pictured on the buttons, cast iron and ferrite/pearlite.

[Save As]

This button can save the current preset under a different name.

[Properties...]

You can modify the name and the sample image of the current preset by selecting this button.

[Delete]

This button deletes the current preset.

Select Detection Type

The following detection types are available according to the selected [Structure Type]:
structure type:

- **Simple** - a predefined detection procedure. The procedure steps depend on the selected structure type.
- **Advanced** - enables to define a custom sequence of commands within the pre/postprocessing portions of the detection procedure.
- **Macro** - enables to load an external macro which would perform the whole detection procedure including threshold.

Detection Procedure

The detection procedure typically consists of three image operations:

- **Image preprocessing** - adjusts the image in order to enhance the important image features (object borders, etc.) so the afterward thresholding would be reliable.
- **Thresholding** - a binary image containing detected objects is the result of thresholding.
- **Binary image postprocessing** - aims to clean the binary image from any unwanted noise and other inaccuracies.

Preprocessing

The following preprocessing operations are available according to the selected [Detection type]. Click the preprocessing button to include the operation in the detection procedure.

- **Correct background inhomogeneity**
Threshold

Specifying correct threshold limits is a crucial task of image analysis. The point is to determine, which pixels will and which will not be included in the binary layer, and thereby distinguish analyzed objects from the background.

Please, see the [Threshold for Metalography] of this chapter for further details.

Postprocessing

The following binary layer postprocessing operations are available according to the selected [Detection type]. Click the icon to include the operation in the detection procedure.

- Clean - deletes the smallest binary objects of the binary layer.

[Save], [Cancel]

Whenever the detection settings are changed, these buttons becomes enabled. You can always use the [Save] button to store the changes to the current preset, or the [Cancel] button to discard them.
Measurement Options

Once the Cast Iron application is run, the [Measurement] tab appears in the right-side docking pane.

- Select the measurement method in [Measurement Presets].
- Adjust the [Test Mask] proportions and size.
- Select the [Standard] according to how the results shall be treated.
- Set [Restrictions] parameters to exclude objects of extreme values.
- Class colors of the [Shape Classifier] can be modified. The classification rules can be modified using a training procedure. Click the [Modify Classifier] button, select a class, and pick typical objects from the image. However, the default classifier settings are based on the selected ASTM/JIS standard, so it is not recommended to modify them in any way.
- Use the [Save] button to store changes of the current method, or use the [Save As] button to add the current settings as a new measurement preset, then press the [Save] button to store the setting.
**Test Mask Options**

Press the [Show Mask] button on the left toolbar to display the mask. The test mask dimensions can be modified either by inserting values inside the edit boxes, or by dragging the node points inside the picture by mouse.

**Fit to screen**

Check this box to maximize the test mask to the whole image area. Some edit boxes get disabled then.

**Fit to Centre**

Press this button to move the whole test mask to the middle of the image area.

**Default Size**

Press this button to reset the user settings and resize the test mask according to the standard.
Measurement

Once the detection and measurement options are set and saved, run the [Measure > Measure] command. The measurement will be performed and the results will be written to the [Data] table. The detected grains will be indicated inside the image.

Since the automated system can make mistakes, it is required to confirm the correctness of each measurement. Use the following tools (placed on the left toolbar) for corrections:

**Separate** - Use this tool to separate graphite manually if some have been detected incorrectly. It is recommended to increase transparency of the binary layer [Ctrl + Down], the object borders become enhanced.

**Delete** - deletes continuous areas of the binary layer after they are clicked on.

**Connect** - creates a connection between two neighboring graphites. Draw the connection by mouse.

**Show Mask** - displays/hides the test mask. If the mask is moved before the measurement results are accepted, the image is re-measured according to the new placement of the mask.

**Show Labels** - displays labels within the image.

**Finish Measurement** - saves the current measurement results to the [Data] table. The system becomes ready to measure the next field (image).

**Skip Measurement** - when measuring a sequence of images, this button discards the results of a single measurement.

**Cancel Measurement** - discards results of the current measurement.
Sequential Measurement

- Place the images that you want to analyze sequentially to one folder.
- Select the [Measure > Measure Sequence] command.
- A dialog window appears. Set the right [Images of Type] that will be displayed in the images list.
- Select the images to be analyzed with mouse: one by one holding the [Ctrl] key down, or select a range holding the [Shift] key down.
- Run the batch process by clicking the [Measure] button.
- Confirm each single measurement the same way as if working with a single image.
**Resulting data**

The data docking window is placed at the bottom of the application screen by default and is divided into thirds.

![Data Table](image)

**Data Table**

The table includes results of all quantities measured. You have the following options how to treat the data:

- **Object/Field Data** - Select what data to display in the left part of the window from the [Object Data/Field Data] pull-down menu. Object data describe each detected grain, field data describe the field (one measurement action) statistics.

- **Reset Data** - erases all data.

- **Show Data** - unselecting this button can hide the object/field data table.

- **Show Statistics** - displays an additional table where overall statistics (Mean, Standard Deviation, Minimum, Maximum) are displayed.

- **Show Histogram** - expands the control window by a histogram of the currently displayed data.

- **Export** - please, see the [Exporting Results] of this manual for further details about this pull-down menu.

- **Options** - this pull-down menu consists of additional commands. It is possible to load/save complete measurement settings to/from an external (*.meas) file.
**Method statistics**

The central portion of the window is occupied by statistics on all fields.

**Histogram**

Optionally, histogram of the displayed data can be displayed. There are the following options.

- **A Pull-down menu serving** for selecting a measurement feature, the distribution of which shall be displayed.

- The minimized **Export** pull-down menu. Please, see the [Exporting Results] of this manual for further details.

- **Graph/Table** - you can switch between the graph and the table view via these buttons. The histogram source data are displayed in the table view.

- **All Data** - the resulting data can be grouped by any of the table values (dragging the column caption to the gray area above the data table will create the groups). Records with matching values are put to the same group. This arrangement enables you to compare statistics of these groups in the histogram:
  - Group the results according to one or more columns.
  - Click the [All Data] button. A pop-up window appears displaying the list of groups or their combinations.
  - Holding the [Ctrl] key down, select the groups you would like to display in the histogram. A color will be assigned to each group.
  - To discard the grouped display, select the [All Data] option on the top of the list.
Histogram Options
Apart from common appearance settings like color, line width, or default text descriptions of the histogram items there are the following options in the dialog window:

Mode
In the [Mode] pull-down menu, you can select the way of displaying the Y axis (number, number in %, cumulative, cumulative in %).

Line histogram
The histogram can be switched to be displayed as a continuous line instead of a number of bars.

Bins Definition
Select the [Bins] tab in order to adjust the way bins of the histogram are created. If the histogram bins shall be equidistant, bin width, minimum and maximum values can be set. If non-equidistant, each bin limit values should be put inside the definition table.
### 8.3.2 Grain Size Analysis Module

After the module installation, a new item called [Metalography] appears in the [Applications] menu. Select the [Grain Size] command to run the application. The appearance (toolbars and the main menu) of the application will be modified.

**Main Features of the Grain Size Analysis Module:**
- Measurement of single-phase structures (e.g. Austenite, Aluminium).
- Measurement of two-phase structures (e.g. Ferrite-Austenite, Ferrite-Pearlite).
- Planimetric, Linear, Circular, and Abrams measurement methods.
- Customization of the predefined measurement procedures.
- Easy data export.

**Quick Guide**

- Open/acquire the image to analyze.
- Set the structure type and the detection procedure parameters within the [Detection] tab.
- Set the measurement procedure parameters within the [Measurement] tab.
- Run the [Measure > Measure] command.
- View the measured data within the [Data] tab and export it to one of the available outputs via the [Export] button

*The analysis can be performed even on two or more images sequentially. After defining all the parameters, run the [Measure > Measure Sequence] command.*
Detection Options

Once the Grain Size application is run, the [Detection] tab appears in the right-side docking pane.

- Select one of the structure types (presets). This selection influences the set of available detection tools.
- Select the detection type. One of the easy modes can be selected, or an arbitrary sequence of operations can be created.
- Enable/disable the pre/post-processing operations, and adjust the [Threshold] settings.
- Use the [Save] button to store changes of the current preset, or use the [Save As] button to add the current settings as a new preset, then press the [Save] button to store the setting.

Select Structure Type

- The [1] and [2] buttons stand for the number of structure phases.
- Select a particular structure type from the nearby pull-down menu.
- If needed, adjust the name and the color of each phase in the table below.

[Save As]

This button can save the current preset under a different name.

[Properties..]

You can modify the name and the sample image of the current preset by selecting this button.
Select Detection Type
The following detection types are available according to the selected structure type:

- Light grains with dark boundaries
- Dark grains with light boundaries
- Contrast grains
- Contrast grains with boundaries
- Simple - a predefined detection procedure. The procedure steps depend on the selected structure type.
- Advanced - enables to define a custom sequence of commands within the pre/postprocessing portions of the detection procedure.
- Macro - enables to load an external macro which would perform the whole detection procedure including threshold.

Detection Procedure
The detection procedure typically consists of three image operations:

- Image preprocessing - adjusts the image in order to enhance the important image features (grain borders, etc.) so the afterward thresholding would be reliable.
- Thresholding - a binary image containing detected objects is the result of thresholding.
- Binary image postprocessing - aims to clean the binary image from any unwanted noise and other inaccuracies.

Preprocessing
The following preprocessing operations are available according to the selected [Detection type]. Click the preprocessing button to include the operation in the detection procedure.

- Correct background inhomogeneity
- Smooth (3 levels)
Threshold
Specifying correct threshold limits is a crucial task of image analysis. The point is to
determine, which pixels will and which will not be included in the binary layer, and
thereby distinguish analyzed objects from the background.

*Please, see the [Threshold for Metalography] of this chapter for further details.*

Postprocessing
The following binary layer postprocessing operations are available according to the
selected [Detection type]. Click the icon to include the operation in the detection
procedure.

- **Delete grains smaller than ...** - detected objects smaller than the defined limit are
  excluded from the binary layer.
- **Separate grains** - an automatic procedure which separates the grains connected
  accidentally by the thresholding procedure.

*[Save], [Cancel]*
Whenever the detection settings are changed, these buttons becomes enabled. You can
always use the [Save] button to store the changes to the current preset, or the [Cancel]
button to discard them.
Measurement Options

Once the Grain Size application is run, the [Measurement] tab appears in the right-side docking pane.

- Select the measurement method in [Measurement Presets].
- Adjust the [Test Mask] proportions and size.
- Select the [Standard] according to how the results shall be treated.
- Set [Restrictions] parameters to exclude objects of extreme values.
- Use the [Save] button to store changes of the current method, or use the [Save As] button to add the current settings as a new measurement preset, then press the [Save] button to store the setting.

Measurement Methods

Planimetric, Linear, Circular, and Abrams measurement methods are available (represented by the topmost buttons). Each method determines the shape of the test mask.

[Save As]
This button can save the current preset under a different name.

[Properties]
You can modify the name and the sample image of the current preset by selecting this button.

[Delete]
This button deletes the current preset.
**Test Mask Options**

Press the [Show Mask] button on the left toolbar to display the mask. The test mask dimensions can be modified either by inserting values inside the edit boxes, or by dragging the node points inside the picture by mouse.

**Fit to screen**

Check this box to maximize the test mask to the whole image area. Some edit boxes get disabled then.

**Fit to Centre**

Press this button to move the whole test mask to the middle of the image area.

**Default Size**

Press this button to reset the user settings and resize the test mask according to the standard.
Measurement

Once the detection and measurement options are set and saved, run the [Measure > Measure] command. The measurement will be performed and the results will be written to the [Data] table. The detected grains or intersections with grain borders will be indicated inside the image.

Since the automated system can make mistakes, it is required to confirm the correctness of each measurement. Use the following tools (placed on the left toolbar) for corrections:

- **Separate Grains** (planimetric method) - Use this tool to draw grain borders manually if some have been detected incorrectly. It is recommended to increase transparency of the binary layer [Ctrl + Down], the grain borders become enhanced.
- **Delete Grain** (planimetric method) - deletes continuous areas of the binary layer after they are clicked on.
- **Connect Grains** (planimetric method) - creates a connection between two neighboring grains. Draw the connection by mouse.
- **Smart Delete Grain** (planimetric method) - click the area to be deleted, and the system automatically unites it with one of the neighboring areas. This tool preserves the size of the whole detected area.
- **Add/Remove Intersection** (intersection methods) - adds an intersection point on the measurement mask, or removes an existing one.
- **Delete Segment** (intersection methods) - point the mouse cursor between two intersection points, and the line segment will be removed from the measurement when clicked.
- **Show Mask** - displays/hides the vector test mask. If the mask is moved before the measurement results are accepted, the image is re-measured according to the new placement of the mask.
- **Display in Colors** - displays the detected line segments or grains in different colors.
- **Show Labels** – displays labels within the image.

**Finish Measurement** - saves the current measurement results to the [Data] table. The system becomes ready to measure the next field (image).

**Skip Measurement** - when measuring a sequence of images, this button discards the results of a single measurement.

**Cancel Measurement** - discards results of the current measurement.
Sequential Measurement

- Place the images that you want to analyze sequentially to one folder.
- Select the [Measure > Measure Sequence] command.
- A dialog window appears. Set the right [Images of Type] that will be displayed in the images list.
- Select the images to be analyzed with mouse: one by one holding the [Ctrl] key down, or select a range holding the [Shift] key down.
- Run the batch process by clicking the [Measure] button.
- Confirm each single measurement the same way as if working with a single image.
Resulting data

The data docking window is placed at the bottom of the application screen by default and is divided into thirds.

Data Table

The table includes results of all quantities measured. Only the fields/objects measured by the currently selected method appear in the table. You have the following options how to treat the data:

- **Object/Field Data** - Select what data to display in the left part of the window from the [Object Data/Field Data] pull-down menu. Object data describe each detected grain, field data describe the field (one measurement action) statistics.

- **Reset Data** - erases all data of the currently selected method.

- **Show Data** - unselecting this button can hide the object/field data table.

- **Show Statistics** - displays an additional table where overall statistics (Mean, Standard Deviation, Minimum, Maximum) are displayed.

- **Show Histogram** - expands the control window by a histogram of the currently displayed data.

- **Export** - please, see the [Exporting Results] of this manual for further details about this pull-down menu.

- **Options** - this pull-down menu consists of additional commands. It is possible to load/save complete measurement settings to/from an external (*.meas) file.

Method statistics

The central portion of the window is occupied by statistics on all fields of the currently selected measurement method.
Histogram
Optionally, histogram of the displayed data can be displayed. There are the following options.

- **A Pull-down menu** serving for selecting a measurement feature, the distribution of which shall be displayed.
- The minimized **Export** pull-down menu. Please, see the [Exporting Results] of this manual for further details.
- **Graph/Table** - you can switch between the graph and the table view via these buttons. The histogram source data are displayed in the table view.
- **All Data** - the resulting data can be grouped by any of the table values (dragging the column caption to the gray area above the data table will create the groups). Records with matching values are put to the same group. This arrangement enables you to compare statistics of these groups in the histogram:
  - Group the results according to one or more columns.
  - Click the [All Data] button. A pop-up window appears displaying the list of groups or their combinations.
  - Holding the [Ctrl] key down, select the groups you would like to display in the histogram. A color will be assigned to each group.
  - To discard the grouped display, select the [All Data] option on the top of the list.

Histogram Options
Apart from common appearance settings like color, line width, or default text descriptions of the histogram items there are the following options in the dialog window:

**Mode**
In the [Mode] pull-down menu, you can select the way of displaying the Y axis (number, number in %, cumulative, cumulative in %).

**Line histogram**
The histogram can be switched to be displayed as a continuous line instead of a number of bars.

**Bins Definition**
Select the [Bins] tab in order to adjust the way bins of the histogram are created. If the histogram bins shall be equidistant, bin width, minimum and maximum values can be set. If non-equidistant, each bin limit values should be put inside the definition table.
8.3.3 Advanced Detection

The preprocessing and postprocessing portions of the detection procedure may be customized. Select the [Detection type > Advanced] option. An editable table where single processing functions can be inserted appears within the [Detection] window.

The following tools are available:

Add function - opens a list of available functions.

Remove function - removes the selected function from the procedure.

Preview - performs the so-far-defined procedure from the beginning to the selected function, and displays results.

Edit function - enables to adjust parameters of the selected function.

Original image - overrides all image changes and displays the original image.

Image Preprocessing

The first step of a successful detection is preprocessing. Prepare the image for the detection:

- Press the [Add function] button. The list of available functions appears.
- Select functions from the list and press the [Add] button to include each one in the preprocessing. Or, double click the function names. [Close] the list.
• Within the selected functions, pick the ones you would like to change the parameters of. When a function has some editable parameters (ends with "..."), the [Edit function] button becomes active. Press it to modify the parameters.

• When the [Preview] button is clicked, all the operations above the selected one are performed subsequently, and the preview image appears.

• Any function can be removed from the procedure by pressing the [Remove function] button.

• Any function can be moved within the list by the arrow buttons in the top right corner of the window.

**Objects Detection - Threshold**

Specifying correct threshold limits is a crucial task of image analysis. The point is to determine, which pixels will and which will not be included in the binary layer, and thereby distinguish analyzed objects from the background.

*Please, see the [Threshold for Metalography] of this chapter for further details.*

**Binary Layer Postprocessing**

It is usually needed to process the detected binary objects using some morphology functions. Proceed in the same way as with preprocessing.
8.3.4 Threshold for Metalography

Specifying correct threshold limits is a crucial procedure of the automated image analysis. The point is to determine, which pixels will and which will not be included in the binary layer, and thereby distinguish analyzed objects from the background. Thresholding can be performed in the following modes:

**RGB Mode**

The [RGB] thresholding mode is available only if an RGB image is opened. To define the [RGB] threshold limits, choose reference points within the image.

To threshold the image use the following tools:

- Single point threshold tool. Select it and click inside the image to define the threshold. The threshold ranges will be adjusted so the selected pixel will fit inside.

- 3 point circle tool picks threshold from the radius of 3 pixels.

- 6 point circle tool picks threshold from the radius of 6 pixels.

- This button erases the threshold settings (no binary objects are created).

- Undo - reverses the previous threshold operation.

- Redo - returns the threshold as it had been before the [Undo] button was used.
Threshold adjustment

Thresholding parameters can be adjusted very precisely in the following way:

- Threshold range of each channel (the colored stripe) can be shifted by mouse. Place the cursor in the middle of the range (a circle appears) and drag it left or right.
- Threshold limits of each channel can be adjusted by mouse. Place the cursor on the edge of the range and drag it left or right.

Intensity Mode

The thresholding procedure works the same way as in the RGB mode except that it is performed on the intensity pixel values.

However, the following thresholding method is added:

- Threshold limits can be adjusted by rewriting the values in the top-left/top-right corner of the histogram.
8.4 Devices

Before you get to work with NIS-Elements, all hardware accessories should be connected properly to the system. In most cases, the following basic procedure is sufficient to connect a device successfully:

- Install NIS-Elements, and select the appropriate devices during the installation.
- Connect the device to a PC and switch the device ON.
- Run NIS-Elements, and run the [Devices > Manage Devices] command to open the Device Manager.
- Use the [Add] button to add the device to NIS-Elements.
- Select the device in the devices list and press the [Connect] button.
- Select logical devices to be activated.
- Configure device-specific settings using the [Configure (physical) Device] and the [(logical) Device Parameters] buttons.
- [Close] the Device Manager.

8.4.1 Logical Devices

NIS-Elements handles hardware accessories using the concept of logical devices. There are some features of different hardware devices which equal, and therefore can be controlled equally. Such features are called "logical devices" for purposes of NIS-Elements. A typical logical device is [Stage XY]. Different microscopes can be equipped with different XY motorized stages, although - regarding the user interface - they behave equally. One physical device (a piece of hardware) can contain one or more logical devices, the list of which appears in the Device Manager after connecting it to NIS-Elements.

Available Logical Devices

Analyzer
The analyzer is a polarizing filter placed in the optical path before the specimen. The logical device offers two states: ON (inserted) and OFF (extracted).

Aperture
This logical device is used for controlling apertures in the light path. It is used in complex microscopes rather than as a standalone device. Typically it contains two controls. One
for switching it ON and OFF (typically a button), and the other for specifying its size (typically an edit-box or a slider).

**Condenser**
A condenser is a two-lens combination located next to the light source in the optical path. Its purpose is to collect light and direct it onto the object being examined. The corresponding logical device relates to a changer of different condensers.

**Filter**
This logical device controls filter changer movements. There can be several filter changers connected to NIS-Elements at a time. Each filter changer needs to be set up - filter types shall be assigned to positions of the changer:
- Display the filter changer control window ([Devices > Filters & Shutters] or [Devices > Microscope Control Pad]).
- Click the setup (…) button, a dialog window appears.
- Select one of the available positions which the filter will be assigned to.
- Select the filter name from the [Predefined]/ [Custom] list of filters.
- Click the [<Set] button.
- The filters can be moved within the already defined positions using the [Up/Down] arrow buttons.

*When browsing the list of filters, details about the currently selected filter are displayed in the right-most portion of the window.*

**Light**
This logical device is used for controlling the specimen illumination remotely. There is not any standard dialog box for the light control. Each device handles this logical device via a specially designed user interface - typically containing one button for ON/OFF switching and a slider for the intensity regulation.

**Light Path**
Some microscopes have more than one port where it is possible to attach a light source or a camera. This logical device can switch the light between these ports.

**Microscope**
This logical device is used to group standalone logical devices used in microscopes. To control the logical devices of a microscope from one control window, select the [Devices > Microscope Control Pad] command.
Nosepiece
This logical device serves for controlling microscope objective changers. There can be three nosepiece types attached to a microscope:

- **Manual** - it cannot be controlled via the [Microscope Control Pad] or the [Nosepiece] control window.
- **Intelligent** - the current nosepiece position is indicated, but cannot be controlled.
- **Motorized** - such nosepieces can be fully controlled via the [Microscope Control Pad] or the [Nosepiece] control window.

Assigning objectives

- To assign an objective (or to change an attached objective assignment) to a position, click the setup ([…]) button.
- A dialog window appears which enables you to select one of the available objectives to the corresponding position.
- Each objective has its specifications displayed in the table. These specifications are not editable.

ND Filter
A neutral-density filter is a light absorbing filter whose absorption spectrum is moderately flat. It is used to reduce the light intensity within the optical path. The logical device offers two states: ON (inserted) and OFF (extracted).

PFS
Perfect Focus System - this logical device corresponds to the PFS physical device available with Nikon TE2000/TI microscopes.

Shutter
This logical device can control shutters installed in your system. This device is handled via the [Devices > Filters & Shutters] control window or straight from the microscope control pad.

Zoom
This logical device is used for controlling the zoom factor. Run the [Devices > Zoom Configuration] command to adjust the zoom settings.
8.5 Nikon Eclipse 90i/80i Microscope

The 90i/80i (fully armed) Microscope Control Pad consists of the following portions:

**Nosepiece**
This portion depends on the type of the connected nosepiece:
- **Manual** - it remains hidden.
- **Intelligent** - it indicates the current nosepiece position, but cannot be controlled.
- **Motorized** - it can be fully controlled.

**Lamp**
The light path accessories that affect light intensity can be controlled here. The condenser turret is controlled by selecting the desired condenser from the pull-down menu.

**Z Drive**
The Z drive movements are indicated/performed via the scrollbar. Tolerance (precision) can be set in the pull-down menu. The higher the tolerance is, the faster the Z drive moves, though less precisely.

**Filter Block Changer**
The standard motorized filter changers control.
8.6 Nikon AZ100 Microscope

When AZ100 is connected to NIS-Elements, the manual remote control gets disabled automatically. The AZ100 Microscope Control Pad consists of the following portions:

**Objectives**

The objectives portion of the pad indicates the nosepiece status: the currently selected objective and objectives magnification. The objective changer cannot be controlled by NIS-Elements.

**Zoom**

Zoom magnification can be changed by moving the scroll bar. The current zoom factor is indicated above. Since the zoom device is a part of the microscope equipment, concerning optical configurations, its settings are automatically treated as an inseparable part of [microscope settings].

**Condenser**

The green button indicates the current condenser lens position (Low/High). The condenser cannot be controlled.

**Z Drive**

The Z drive can be controlled via the microscope control pad in the following way:

- The [up/down arrows] move the Z drive by a defined [Step].
- The current position can be memorized by pressing the [Set] button. The position value will be written to the pull-down menu.
- To move the Z drive to a memorized position, select the desired value from the pull-down menu and press the [Go] button.
- The current position is indicated below the [Step] edit box.
FilterBlocks
The currently selected filter of the four available filter positions is indicated in the Filter Blocks portion of the pad. The filter changer cannot be controlled by NIS-Elements. Filters assignment may be changed after pressing the [...] button.
8.7 Nikon Eclipse LV Series Microscope

The LV (fully armed) Microscope Control Pad consists of the following portions:

**Nosepiece**

The motorized objective changer can be controlled via this portion of the dialog window.

**Accessories**

Intensity of episcopic and diascopic light sources can be controlled.

**Z Drive**

The motorized Z drive is controllable too. Clicking the arrow buttons moves Z drive by the step defined in the pull-down menu. The [Escape] button clears the objectives of the stage reach. The bottommost position (lower limit) of the Z drive can be set using the [Set Limit] button. The [Clear Limit] button discards the setting.

*Please make sure to set [Lower limit] before using the microscope. Otherwise, the objective can accidentally hit the stage when the motorized Z drive moves.*

**Filter Blocks**

There are 4 available positions in the changer. The first two have fixed filters for bright field (BF) and dark field (DF) microscopy. The other two are available for any filters to be inserted.
8.8 Nikon MM 400/800 Microscopes

The measuring microscope connected to NIS-Elements provides two logical devices:

**Nosepiece**

Two types of nosepiece can be attached to the microscope:

- **Manual** - cannot communicate with the computer. Each time you switch the objectives, you should also select a position in the Nosepiece control window accordingly.

- **Intelligent** - cannot be controlled by the system, but when you change the objective manually, it indicates the change in the Nosepiece control window automatically.

After adding the MM microscope to the system via Device Manager, the [Nosepiece] logical device becomes available. Display its control window by the [View > Acquisition Controls > Nosepiece] command. The type of the nosepiece must be defined via the hardware control pad in order to be recognized by NIS-Elements.

**Z Drive**

The Measuring Microscopes Z drive may be moved using the [View > Acquisition Controls > XYZ Navigation] control window.
8.9 Nikon MA200 Inverted Metallurgical Microscope

The MA200 Microscope Control Pad consists of the following portions:

**Nosepiece**
The motorized objective changer can be controlled via this portion of the dialog window. If a move from position 1 to position 5 is ordered, a warning appears. This behavior shall prevent the high magnification objectives to strike the XY stage.

**Light**
A halogen lamp or the Nikon Intensilight illumination device can be attached to the microscope and controlled from here. If the halogen lamp is attached to the microscope, internal (manual) or external (via NIS-Elements) control can be selected on the back of the microscope body.

**Shutter**
The shutter is a part of the Intensilight device and can be controlled from here.

**Intermediate Magnification**
This portion of the pad indicates the current state of the intermediate magnification device. There are three predefined magnifications (1x, 1.5x, 2x).
8.10 Nikon TE2000 Microscope

The TE2000 (fully armed) Microscope Control Pad consists of the following portions:

**Nosepiece**

The motorized objective changer can be controlled via this portion of the dialog window.

**Light**

Complete light path accessories can be controlled here. Switch the light between ports as needed.

**Condenser**

The condenser turret is controlled by selecting the desired condenser from a pull-down menu.

**Z Drive**

The Z drive position is indicated, or can be controlled, via a scrollbar.

**PFS**

The functionality of the PFS-section of the control pad corresponds to the hardware controller.

**Filter Changers**

Standard motorized filter changer controls. You can select whether filter colors or position numbers are displayed on the buttons.
8.11 Nikon TI Microscope

The TI (fully armed) Microscope Control Pad consists of the following portions:

**Nosepiece**

The nosepiece can be controlled here. The objective settings are being shared between NIS-Elements and the microscope RCP.

**Light Path**

The light path control buttons correspond to the buttons placed on the microscope body.

**PFS**

This optional accessory can be controlled via the pad. The offset value can be put straight in the edit box. When you are about to turn the PFS ON, make sure the [Focus] indicator shines. It indicates that the PFS is ready to get to the defined offset position.* The [Memory] and [Recall] buttons equal the buttons on the microscope body.

* - Vast shift of the Z drive can cause that PFS will not be able to refocus. That is when the [Focus] indicator stops shining.

**Z Drive**

The integrated Z drive movements are performed by the up/down arrows. Tolerance (precision) can be set in the pull-down menu on the right. The tolerance setting affects the Z drive speed slightly.

**Lamp**

Three types of illumination devices can be attached: Diascopic lamp, Intensilight fiber illuminator, TIRF illuminator. All these devices are controllable by the pad.
**TIRF** - A shutter can be assigned to close every time the TIRF position is being changed. To do so, right-click the TIRF logical device within the [Device Manager] window and select the shutter type from the context menu.

**Shutters**
Register the correct shutter types in the RCP. Then, the shutters can be controlled by NIS-Elements.

**Piezo Z**
An optional piezo stage is controlled equally to the Z Drive device. The piezo Z component should be registered via RCP, and direct USB cable must be used between PC and the microscope body (not the HUB connection).

**Filters**
The standard motorized filter changer control. The [Analyzer] button appears, when the [ANALYZER] filter type is assigned to one position of the turret. Press the [IN/OUT] button to insert/extract the analyzer.

**Condenser**
The condenser turret is controlled by selecting the desired condenser from the pull-down menu.